summary refs log tree commit diff
path: root/distro
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-09-01 19:21:06 +0200
committerLudovic Courtès <ludo@gnu.org>2012-09-02 16:05:41 +0200
commit472894aae8b59fa45dccb2b9cef9ff6ed27b152d (patch)
tree5caaf30982baaaf028723fcad314e742cb8719f1 /distro
parent946b72c92408c59ac02d0f97d4e241a9098d742f (diff)
downloadguix-472894aae8b59fa45dccb2b9cef9ff6ed27b152d.tar.gz
distro: tar: Allow builds with glibc 2.16+.
* distro/patches/tar-gets-undeclared.patch: New file.
* Makefile.am (dist_patch_DATA): Add it.

* distro/base.scm (tar): Apply. `tar-gets-undeclared.patch'.
Diffstat (limited to 'distro')
-rw-r--r--distro/base.scm3
-rw-r--r--distro/patches/tar-gets-undeclared.patch26
2 files changed, 29 insertions, 0 deletions
diff --git a/distro/base.scm b/distro/base.scm
index 7ff15ad2eb..78beb9f6c3 100644
--- a/distro/base.scm
+++ b/distro/base.scm
@@ -163,6 +163,9 @@ substituting multiple occurrences of a string within a file.")
              (base32
               "0hbdkzmchq9ycr2x1pxqdcgdbaxksh8c6ac0jf75jajhcks6jlss"))))
    (build-system gnu-build-system)
+   (inputs `(("patch/gets" ,(search-patch "tar-gets-undeclared.patch"))))
+   (arguments
+    `(#:patches (list (assoc-ref %build-inputs "patch/gets"))))
    (description "GNU implementation of the `tar' archiver")
    (long-description
     "The Tar program provides the ability to create tar archives, as well as
diff --git a/distro/patches/tar-gets-undeclared.patch b/distro/patches/tar-gets-undeclared.patch
new file mode 100644
index 0000000000..301a09dde1
--- /dev/null
+++ b/distro/patches/tar-gets-undeclared.patch
@@ -0,0 +1,26 @@
+This patch is needed to allow builds with newer versions of
+the GNU libc (2.16+).
+
+This is a backport of this patch:
+
+commit 66712c23388e93e5c518ebc8515140fa0c807348
+Author: Eric Blake <eblake@redhat.com>
+Date:   Thu Mar 29 13:30:41 2012 -0600
+
+    stdio: don't assume gets any more
+    
+--- tar-1.26/gnu/stdio.in.h	2012-07-02 14:28:45.000000000 +0200
++++ tar-1.26/gnu/stdio.in.h	2012-07-02 14:28:50.000000000 +0200
+@@ -160,12 +160,6 @@ _GL_WARN_ON_USE (fflush, "fflush is not
+                  "use gnulib module fflush for portable POSIX compliance");
+ #endif
+ 
+-/* It is very rare that the developer ever has full control of stdin,
+-   so any use of gets warrants an unconditional warning.  Assume it is
+-   always declared, since it is required by C89.  */
+-#undef gets
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+-
+ #if @GNULIB_FOPEN@
+ # if @REPLACE_FOPEN@
+ #  if !(defined __cplusplus && defined GNULIB_NAMESPACE)