summary refs log tree commit diff
path: root/distro
diff options
context:
space:
mode:
authorNikita Karetnikov <nikita@karetnikov.org>2012-12-07 01:18:23 +0000
committerLudovic Courtès <ludo@gnu.org>2012-12-07 22:32:00 +0100
commit6ad2697d2375f508db740e4c10f8c50eac449632 (patch)
treecc379f1759484f79d1412b2ddbfad230f5b94bd7 /distro
parent3d282f90f870f120d541c657a1278eeeee069f43 (diff)
downloadguix-6ad2697d2375f508db740e4c10f8c50eac449632.tar.gz
distro: Add ACL.
* distro/packages/acl.scm: New file.  Dependency on Perl added by
  Ludovic.
* Makefile.am (MODULES): Add it.
Diffstat (limited to 'distro')
-rw-r--r--distro/packages/acl.scm61
1 files changed, 61 insertions, 0 deletions
diff --git a/distro/packages/acl.scm b/distro/packages/acl.scm
new file mode 100644
index 0000000000..a119b5bf52
--- /dev/null
+++ b/distro/packages/acl.scm
@@ -0,0 +1,61 @@
+;;; Guix --- Nix package management from Guile.         -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Nikita Karetnikov <nikita@karetnikov.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages acl)
+  #:use-module (distro packages attr)
+  #:use-module (distro packages perl)
+  #:use-module ((distro packages gettext)
+                #:renamer (symbol-prefix-proc 'guix:))
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu))
+
+(define-public acl
+  (package
+    (name "acl")
+    (version "2.2.51")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://savannah/acl/acl-"
+                          version ".src.tar.gz"))
+      (sha256
+       (base32
+        "09aj30m49ivycl3irram8c3givc0crivjm3ymw0nhfaxrwhlb186"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (alist-replace 'check
+                      (lambda _
+                        (patch-shebang "test/run")
+                        (system* "make" "tests" "-C" "test")
+
+                        ;; XXX: Ignore the test result since this is
+                        ;; dependent on the underlying file system.
+                        #t)
+                      %standard-phases)))
+    (inputs `(("attr" ,attr)
+              ("gettext" ,guix:gettext)
+              ("perl" ,perl)))
+    (home-page
+     "http://savannah.nongnu.org/projects/acl")
+    (synopsis
+     "Library and tools for manipulating access control lists")
+    (description
+     "Library and tools for manipulating access control lists.")
+    (license '("GPLv2+" "LGPLv2.1+"))))