summary refs log tree commit diff
path: root/doc.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-08-27 00:36:41 +0200
committerLudovic Courtès <ludo@gnu.org>2015-08-27 00:49:23 +0200
commit888569161c0cb55a2700806aded7128cfe605857 (patch)
tree116f9191b62d4a09575d6e811c906f54d3828241 /doc.am
parent12e5b26643e2269e8f30d8399886d4302c3c09d1 (diff)
downloadguix-888569161c0cb55a2700806aded7128cfe605857.tar.gz
Add 'guix graph'.
* guix/scripts/graph.scm, tests/graph.scm, tests/guix-graph.sh,
  doc/images/coreutils-bag-graph.dot, doc/images/coreutils-graph.dot: New
  files.
* Makefile.am (MODULES): Add guix/scripts/graph.scm.
  (SH_TESTS): Add tests/guix-graph.sh.
  (SCM_TESTS): Add tests/graph.scm.
* doc.am (DOT_FILES, DOT_VECTOR_GRAPHICS): New variables.
  (EXTRA_DIST): Use them.
  (dist_infoimage_DATA): Use $(DOT_FILES).
  (pdf-local, info-local, ps-local): Likewise.
* doc/guix.texi (Packages with Multiple Outputs): Add cross-reference to 'guix
  graph'.
  (Invoking guix gc): Likewise.
  (Invoking guix graph): New section.
Diffstat (limited to 'doc.am')
-rw-r--r--doc.am23
1 files changed, 16 insertions, 7 deletions
diff --git a/doc.am b/doc.am
index 1f0b8328e1..9c1dc83e88 100644
--- a/doc.am
+++ b/doc.am
@@ -18,13 +18,22 @@
 # along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 info_TEXINFOS = doc/guix.texi
+
+DOT_FILES =					\
+  doc/images/bootstrap-graph.dot		\
+  doc/images/coreutils-graph.dot		\
+  doc/images/coreutils-bag-graph.dot
+
+DOT_VECTOR_GRAPHICS =				\
+  $(DOT_FILES:%.dot=%.eps)			\
+  $(DOT_FILES:%.dot=%.pdf)
+
 EXTRA_DIST +=					\
   doc/contributing.texi				\
   doc/emacs.texi				\
   doc/fdl-1.3.texi				\
-  doc/images/bootstrap-graph.dot		\
-  doc/images/bootstrap-graph.eps		\
-  doc/images/bootstrap-graph.pdf		\
+  $(DOT_FILES)					\
+  $(DOT_VECTOR_GRAPHICS)			\
   doc/images/coreutils-size-map.eps		\
   doc/environment-gdb.scm			\
   doc/package-hello.scm
@@ -44,7 +53,7 @@ doc/os-config-%.texi: gnu/system/examples/%.tmpl
 
 infoimagedir = $(infodir)/images
 dist_infoimage_DATA =				\
-  doc/images/bootstrap-graph.png		\
+  $(DOT_FILES:%.dot=%.png)			\
   doc/images/coreutils-size-map.png
 
 # Try hard to obtain an image size and aspect that's reasonable for inclusion
@@ -72,9 +81,9 @@ DOT_OPTIONS =					\
 # We cannot add new dependencies to `doc/guix.pdf' & co. (info "(automake)
 # Extending").  Using the `-local' rules is imperfect, because they may be
 # triggered after the main rule.  Oh, well.
-pdf-local: $(top_srcdir)/doc/images/bootstrap-graph.pdf
-info-local: $(top_srcdir)/doc/images/bootstrap-graph.png
-ps-local: $(top_srcdir)/doc/images/bootstrap-graph.eps		\
+pdf-local: $(DOT_FILES=%.dot=$(top_srcdir)/%.pdf)
+info-local: $(DOT_FILES=%.dot=$(top_srcdir)/%.png)
+ps-local: $(DOT_FILES=%.dot=$(top_srcdir)/%.eps)		\
 	  $(top_srcdir)/doc/images/coreutils-size-map.eps
 dvi-local: ps-local