summary refs log tree commit diff
path: root/doc/contributing.texi
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-01-13 18:47:15 +0100
committerLudovic Courtès <ludo@gnu.org>2017-01-13 18:49:31 +0100
commit557d9c8d7a843bf06e75b4e1a742654ccf951fa3 (patch)
treedcd96026be9c5c408ed08f9f3061962c00d0d39d /doc/contributing.texi
parent608a50b66c73d5bdfd224195b839e01b781c354c (diff)
downloadguix-557d9c8d7a843bf06e75b4e1a742654ccf951fa3.tar.gz
etc: Support indentation of whole files.
* etc/indent-package.el.in: Rename to...
* etc/indent-code.el.in: ... this.  Add case for a single argument.
* doc/contributing.texi (Formatting Code): Adjust accordingly.
* configure.ac: Likewise.
Diffstat (limited to 'doc/contributing.texi')
-rw-r--r--doc/contributing.texi11
1 files changed, 8 insertions, 3 deletions
diff --git a/doc/contributing.texi b/doc/contributing.texi
index 9fc1eb54d8..4454df1f98 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -256,12 +256,17 @@ If you do not use Emacs, please make sure to let your editor knows these
 rules.  To automatically indent a package definition, you can also run:
 
 @example
-./etc/indent-package.el gnu/packages/@var{file}.scm @var{package}
+./etc/indent-code.el gnu/packages/@var{file}.scm @var{package}
 @end example
 
 @noindent
 This automatically indents the definition of @var{package} in
-@file{gnu/packages/@var{file}.scm} by running Emacs in batch mode.
+@file{gnu/packages/@var{file}.scm} by running Emacs in batch mode.  To
+indent a whole file, omit the second argument:
+
+@example
+./etc/indent-code.el gnu/services/@var{file}.scm
+@end example
 
 We require all top-level procedures to carry a docstring.  This
 requirement can be relaxed for simple private procedures in the
@@ -374,7 +379,7 @@ or a package update along with fixes to that package.
 
 @item
 Please follow our code formatting rules, possibly running the
-@command{etc/indent-package.el} script to do that automatically for you
+@command{etc/indent-code.el} script to do that automatically for you
 (@pxref{Formatting Code}).
 
 @end enumerate