summary refs log tree commit diff
path: root/doc
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-10-25 09:40:59 +0200
committerAndreas Enge <andreas@enge.fr>2024-10-28 10:41:27 +0100
commit351fdf69f737d09d24499d6c1ff70a2325fff0fa (patch)
tree1cca5cc5d0dbb834d0a0d2926767a11d8382f2b6 /doc
parent5034f2d45c2a307ebaad6e99957f3b3a4d8cdd0a (diff)
downloadguix-351fdf69f737d09d24499d6c1ff70a2325fff0fa.tar.gz
gnu: postgresql: Deprecate unsupported versions.
Versions 10 and 11 are unsupported according to
https://www.postgresql.org/support/versioning/

postgresql-10 also has a CVE.

* doc/guix.texi: Change default value of postgresql-service-type's
postgresql field.
* gnu/packages/databases.scm (postresql-10, postgresql-11): Use
define-deprecated/public to warn users.
* gnu/services/databases.scm (postgresql-configuration): Change the
default value of postgresql-configuration-postgresql.
* gnu/tests/guix.scm (%guix-data-service-os): Change the default value
of postgresql.

Signed-off-by: Andreas Enge <andreas@enge.fr>
Change-Id: Ie8744c8e1f246e9b45ff5e29d4e98214de3ca66a
Diffstat (limited to 'doc')
-rw-r--r--doc/guix.texi6
1 files changed, 3 insertions, 3 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index ac3a7adef0..5768e195b0 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -26192,7 +26192,7 @@ configuration.
 @lisp
 (service postgresql-service-type
          (postgresql-configuration
-          (postgresql postgresql-10)))
+          (postgresql postgresql)))
 @end lisp
 
 If the services fails to start, it may be due to an incompatible
@@ -26219,7 +26219,7 @@ Data type representing the configuration for the
 @code{postgresql-service-type}.
 
 @table @asis
-@item @code{postgresql} (default: @code{postgresql-10})
+@item @code{postgresql} (default: @code{postgresql})
 PostgreSQL package to use for the service.
 
 @item @code{port} (default: @code{5432})
@@ -26261,7 +26261,7 @@ configure the postgresql-service as in this example:
     (cons*
       (service postgresql-service-type
                (postgresql-configuration
-                (postgresql postgresql-10)
+                (postgresql postgresql)
                 (extension-packages (list postgis))))
       %base-services)))
 @end lisp