summary refs log tree commit diff
path: root/doc
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-08 12:18:13 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-22 16:09:04 -0400
commit8005e09b261d65bf0f7469cd8e89423c1c1db820 (patch)
treef98b345a8de8dfeb831e6d20fd82f4890936d825 /doc
parentfaeebdc37e9137d62e11175e83988f77496a6641 (diff)
downloadguix-8005e09b261d65bf0f7469cd8e89423c1c1db820.tar.gz
build: Add a commit-msg hook that embeds Change-Id in commit messages.
Partially implements <https://issues.guix.gnu.org/66027>.

This will make it possible to track a merged commit back to its original
posting on the mailing list, and open the door to new opportunities such as
closing fully merged series automatically.

* Makefile.am (COMMIT_MSG_MAGIC): New variable.
(.git/hooks/commit-msg): New target.
* etc/git/commit-msg: New file.
* doc/contributing.texi (Configuring Git): Document Change-Id.

Series-changes: 3
 - Clarify documentation text, as suggested by Simon
Change-Id: Ia92fa958eae600fdd4e180bad494c85db8bb4dd6
Reviewed-by: Simon Tournier <zimon.toutoune@gmail.com>
Diffstat (limited to 'doc')
-rw-r--r--doc/contributing.texi10
1 files changed, 9 insertions, 1 deletions
diff --git a/doc/contributing.texi b/doc/contributing.texi
index 864190b119..43cfae26c4 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -1575,8 +1575,16 @@ different name or email just for commits in this repository, you can
 use @command{git config --local}, or edit @file{.git/config} in the
 repository instead of @file{~/.gitconfig}.
 
+@cindex commit-msg hook
 Other important Git configuration will automatically be configured when
-building the project (@pxref{Building from Git}).
+building the project (@pxref{Building from Git}).  A
+@file{.git/hooks/commit-msg} hook will be installed that embeds
+@samp{Change-Id} Git @emph{trailers} in your commit messages for
+traceability purposes.  It is important to preserve these when editing
+your commit messages, particularly if a first version of your proposed
+changes was already submitted for review.  If you have a
+@file{commit-msg} hook of your own you would like to use with Guix, you
+can place it under the @file{.git/hooks/commit-msg.d/} directory.
 
 @node Sending a Patch Series
 @subsection Sending a Patch Series