summary refs log tree commit diff
path: root/doc
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-06 21:16:32 +0200
committerMarius Bakke <marius@gnu.org>2021-06-06 21:16:32 +0200
commit8d59c262ada2e2167196a8fb8cbebd9c329a79dd (patch)
tree85a74de8cc23a2f0179c0b9f0adfa4c274449a0c /doc
parente7f0835b07d868fd447aa64c873174fa385e1699 (diff)
parenta068ed6a5f5b3535fce49ac4eca1fec82edd6fdc (diff)
downloadguix-8d59c262ada2e2167196a8fb8cbebd9c329a79dd.tar.gz
Merge branch 'master' into core-updates
 Conflicts:
	gnu/local.mk
	gnu/packages/algebra.scm
	gnu/packages/bioinformatics.scm
	gnu/packages/curl.scm
	gnu/packages/docbook.scm
	gnu/packages/emacs-xyz.scm
	gnu/packages/maths.scm
	gnu/packages/plotutils.scm
	gnu/packages/python-web.scm
	gnu/packages/python-xyz.scm
	gnu/packages/radio.scm
	gnu/packages/readline.scm
	gnu/packages/tls.scm
	gnu/packages/xml.scm
	gnu/packages/xorg.scm
Diffstat (limited to 'doc')
-rw-r--r--doc/contributing.texi36
-rw-r--r--doc/guix.texi58
2 files changed, 68 insertions, 26 deletions
diff --git a/doc/contributing.texi b/doc/contributing.texi
index c3419912a1..fa8c0cf3ba 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -1018,20 +1018,21 @@ Make sure the package builds on your platform, using @code{guix build
 We recommend you also try building the package on other supported
 platforms.  As you may not have access to actual hardware platforms, we
 recommend using the @code{qemu-binfmt-service-type} to emulate them.  In
-order to enable it, add the following service to the list of services in
-your @code{operating-system} configuration:
+order to enable it, add the @code{virtualization} service module and the
+following service to the list of services in your @code{operating-system}
+configuration:
 
 @lisp
 (service qemu-binfmt-service-type
  (qemu-binfmt-configuration
-   (platforms (lookup-qemu-platforms "arm" "aarch64"))
+   (platforms (lookup-qemu-platforms "arm" "aarch64"))))
 @end lisp
 
 Then reconfigure your system.
 
 You can then build packages for different platforms by specifying the
 @code{--system} option.  For example, to build the "hello" package for
-the armhf, aarch64, or mips64 architectures, you would run the following
+the armhf or aarch64 architectures, you would run the following
 commands, respectively:
 @example
 guix build --system=armhf-linux --rounds=2 hello
@@ -1062,7 +1063,7 @@ and which optional dependencies should be used.  In particular, avoid adding
 the @code{texlive-tiny} package or @code{texlive-union} procedure instead.
 
 @item
-For important changes, check that dependent package (if applicable) are
+For important changes, check that dependent packages (if applicable) are
 not affected by the change; @code{guix refresh --list-dependent
 @var{package}} will help you do that (@pxref{Invoking guix refresh}).
 
@@ -1180,6 +1181,11 @@ MIME attachments.  You are advised to pay attention if your email client
 changes anything like line breaks or indentation which could potentially
 break the patches.
 
+Expect some delay when you submit your very first patch to
+@email{guix-patches@@gnu.org}. You have to wait until you get an
+acknowledgement with the assigned tracking number. Future acknowledgements
+should not be delayed.
+
 When a bug is resolved, please close the thread by sending an email to
 @email{@var{NNN}-done@@debbugs.gnu.org}.
 
@@ -1517,20 +1523,20 @@ doubt, please contact us, we will be happy to help!
 @table @asis
 @item guix
 Guix is written in the Guile programming language, and some strings contain
-special formating that is interpreted by Guile.  These special formating
+special formatting that is interpreted by Guile.  These special formatting
 should be highlighted by Weblate.  They start with @code{~} followed by one
 or more characters.
 
-When printing the string, Guile replaces the special formating symbols with
+When printing the string, Guile replaces the special formatting symbols with
 actual values.  For instance, the string @samp{ambiguous package specification
 `~a'} would be substituted to contain said package specification instead of
-@code{~a}.  To properly translate this string, you must keep the formating
+@code{~a}.  To properly translate this string, you must keep the formatting
 code in your translation, although you can place it where it makes sense in
 your language.  For instance, the French translation says @samp{spécification
 du paquet « ~a » ambiguë} because the adjective needs to be placed in the
 end of the sentence.
 
-If there are multiple formating symbols, make sure to respect the order.
+If there are multiple formatting symbols, make sure to respect the order.
 Guile does not know in which order you intended the string to be read, so it
 will substitute the symbols in the same order as the English sentence.
 
@@ -1538,9 +1544,9 @@ As an example, you cannot translate @samp{package '~a' has been superseded by
 '~a'} by @samp{'~a' superseeds package '~a'}, because the meaning would be
 reversed.  If @var{foo} is superseded by @var{bar}, the translation would read
 @samp{'foo' superseeds package 'bar'}.  To work around this problem, it
-is possible to use more advanced formating to select a given piece of data,
+is possible to use more advanced formatting to select a given piece of data,
 instead of following the default English order.  @xref{Formatted Output,,,
-guile, GNU Guile Reference Manual}, for more information on formating in Guile.
+guile, GNU Guile Reference Manual}, for more information on formatting in Guile.
 
 @item packages
 
@@ -1551,7 +1557,7 @@ and Descriptions}).   Texinfo markup looks like @samp{@@code@{rm -rf@}},
 The characters after ``@@'' form the name of the markup, and the text between
 ``@{'' and ``@}'' is its content.  In general, you should not translate the
 content of markup like @code{@@code}, as it contains literal code that do not
-change with language.  You can translate the content of formating markup such
+change with language.  You can translate the content of formatting markup such
 as @code{@@emph}, @code{@@i}, @code{@@itemize}, @code{@@item}.  However, do
 not translate the name of the markup, or it will not be recognized.  Do
 not translate the word after @code{@@end}, it is the name of the markup that
@@ -1581,10 +1587,10 @@ The manual and the cookbook both use Texinfo.  As for @code{packages}, please
 keep Texinfo markup as is.  There are more possible markup types in the manual
 than in the package descriptions.  In general, do not translate the content
 of @code{@@code}, @code{@@file}, @code{@@var}, @code{@@value}, etc.  You
-should translate the content of formating markup such as @code{@@emph},
+should translate the content of formatting markup such as @code{@@emph},
 @code{@@i}, etc.
 
-The manual contains sections that can be refered to by name by @code{@@ref},
+The manual contains sections that can be referred to by name by @code{@@ref},
 @code{@@xref} and @code{@@pxref}.  We have a mechanism in place so you do
 not have to translate their content.  If you keep the English title, we will
 automatically replace it with your translation of that title.  This ensures
@@ -1664,7 +1670,7 @@ synchronize it with our guix and artworks repositories after checking no issue
 was introduced in the translation.
 
 Developers can download the latest PO files from weblate in the Guix
-repository by runnig the @command{make download-po} target.  It will
+repository by running the @command{make download-po} command.  It will
 automatically download the latest files from weblate, reformat them to a
 canonical form, and check they do not contain issues.  The manual needs to be
 built again to check for additional issues that might crash Texinfo.
diff --git a/doc/guix.texi b/doc/guix.texi
index 3557c977e1..750483706b 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -76,7 +76,7 @@ Copyright @copyright{} 2020 Damien Cassou@*
 Copyright @copyright{} 2020 Jakub Kądziołka@*
 Copyright @copyright{} 2020 Jack Hill@*
 Copyright @copyright{} 2020 Naga Malleswari@*
-Copyright @copyright{} 2020 Brice Waegeneire@*
+Copyright @copyright{} 2020, 2021 Brice Waegeneire@*
 Copyright @copyright{} 2020 R Veera Kumar@*
 Copyright @copyright{} 2020 Pierre Langlois@*
 Copyright @copyright{} 2020 pinoaffe@*
@@ -787,6 +787,13 @@ To use substitutes from @code{@value{SUBSTITUTE-SERVER}} or one of its mirrors
      ~root/.config/guix/current/share/guix/@value{SUBSTITUTE-SERVER}.pub
 @end example
 
+@quotation Note
+If you do not enable substitutes, Guix will end up building
+@emph{everything} from source on your machine, making each installation
+and upgrade very expensive.  @xref{On Trusting Binaries}, for a
+discussion of reasons why one might want do disable substitutes.
+@end quotation
+
 @item
 Each user may need to perform a few additional steps to make their Guix
 environment ready for use, @pxref{Application Setup}.
@@ -833,8 +840,7 @@ GNU Guix is available for download from its website at
 GNU Guix depends on the following packages:
 
 @itemize
-@item @url{https://gnu.org/software/guile/, GNU Guile}, version 3.0.x or
-2.2.x;
+@item @url{https://gnu.org/software/guile/, GNU Guile}, version 3.0.x;
 @item @url{https://notabug.org/cwebber/guile-gcrypt, Guile-Gcrypt}, version
 0.1.0 or later;
 @item
@@ -11624,6 +11630,28 @@ using this mode, the symbol of the package is made by appending the
 version to its name, so that multiple versions of the same package can
 coexist.
 @end table
+
+@item egg
+@cindex egg
+Import metadata for @uref{https://wiki.call-cc.org/eggs, CHICKEN eggs}.
+The information is taken from @file{PACKAGE.egg} files found in the
+@uref{git://code.call-cc.org/eggs-5-latest, eggs-5-latest} Git
+repository.  However, it does not provide all the information that we
+need, there is no ``description'' field, and the licenses used are not
+always precise (BSD is often used instead of BSD-N).
+
+@example
+guix import egg sourcehut
+@end example
+
+Additional options include:
+@table @code
+@item --recursive
+@itemx -r
+Traverse the dependency graph of the given upstream package recursively
+and generate package expressions for all those packages that are not yet
+in Guix.
+@end table
 @end table
 
 The structure of the @command{guix import} code is modular.  It would be
@@ -11778,6 +11806,8 @@ the updater for KDE packages;
 the updater for X.org packages;
 @item kernel.org
 the updater for packages hosted on kernel.org;
+@item egg
+the updater for @uref{https://wiki.call-cc.org/eggs/, Egg} packages;
 @item elpa
 the updater for @uref{https://elpa.gnu.org/, ELPA} packages;
 @item cran
@@ -16450,6 +16480,7 @@ configuration rejecting all incoming connections except those to the ssh port
 :INPUT ACCEPT
 :FORWARD ACCEPT
 :OUTPUT ACCEPT
+-A INPUT -m conntrack --ctstate ESTABLISHED,RELATED -j ACCEPT
 -A INPUT -p tcp --dport 22 -j ACCEPT
 -A INPUT -j REJECT --reject-with icmp-port-unreachable
 COMMIT
@@ -16458,6 +16489,7 @@ COMMIT
 :INPUT ACCEPT
 :FORWARD ACCEPT
 :OUTPUT ACCEPT
+-A INPUT -m conntrack --ctstate ESTABLISHED,RELATED -j ACCEPT
 -A INPUT -p tcp --dport 22 -j ACCEPT
 -A INPUT -j REJECT --reject-with icmp6-port-unreachable
 COMMIT
@@ -19236,7 +19268,7 @@ The MATE package to use.
 @end deftp
 
 @deffn {Scheme Variable} lxqt-desktop-service-type
-This is the type of the service that runs the @uref{https://lxqt.github.io,
+This is the type of the service that runs the @uref{https://lxqt-project.org,
 LXQt desktop environment}.  Its value is a @code{lxqt-desktop-configuration}
 object (see below).
 
@@ -33868,6 +33900,13 @@ every time you modify your @command{config.scm} file and the
 @command{-o StrictHostKeyChecking=no} prevents you from having to allow a
 connection to an unknown host every time you connect.
 
+@quotation Note
+If you find the above @samp{hostfwd} example not to be working (e.g.,
+your SSH client hangs attempting to connect to the mapped port of your
+VM), make sure that your Guix System VM has networking support, such as
+by using the @code{dhcp-client-service-type} service type.
+@end quotation
+
 @subsection Using @command{virt-viewer} with Spice
 
 As an alternative to the default @command{qemu} graphical client you can
@@ -34395,13 +34434,10 @@ This service type is intended to be extended by other service types,
 such as below:
 
 @lisp
-(define module-installing-service-type
-  (service-type
-    (name 'module-installing-service)
-    (extensions (list (service-extension linux-loadable-module-service-type
-                                         (const (list module-to-install-1
-                                                      module-to-install-2)))))
-    (default-value #f)))
+(simple-service 'installing-module
+                linux-loadable-module-service-type
+                (list module-to-install-1
+                      module-to-install-2))
 @end lisp
 
 This does not actually load modules at bootup, only adds it to the