summary refs log tree commit diff
path: root/doc
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-07-31 14:47:34 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-08-31 15:39:34 +0200
commitf8f3bef6aac4ed96bfd236567536c4b039b7bd31 (patch)
treebe52127c468938d127a229a035615815a28c3607 /doc
parente1248602f92c45a731e47e74d3612bee03eaa0da (diff)
downloadguix-f8f3bef6aac4ed96bfd236567536c4b039b7bd31.tar.gz
build: Add R build system.
* guix/build-system/r.scm: New file.
* guix/build/r-build-system: New file.
* Makefile.am (MODULES): Add new files.
* doc/guix.texi (Build Systems): Document r-build-system.
Diffstat (limited to 'doc')
-rw-r--r--doc/guix.texi10
1 files changed, 10 insertions, 0 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 4dbedb15ec..c42aedbbb0 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -2491,6 +2491,16 @@ passes flags specified by the @code{#:make-maker-flags} or
 Which Perl package is used can be specified with @code{#:perl}.
 @end defvr
 
+@defvr {Scheme Variable} r-build-system
+This variable is exported by @code{(guix build-system r)}.  It
+implements the build procedure used by @uref{http://r-project.org, R}
+packages, which essentially is little more than running @code{R CMD
+INSTALL --library=/gnu/store/@dots{}} in an environment where
+@code{R_LIBS_SITE} contains the paths to all R package inputs.  Tests
+are run after installation using the R function
+@code{tools::testInstalledPackage}.
+@end defvr
+
 @defvr {Scheme Variable} ruby-build-system
 This variable is exported by @code{(guix build-system ruby)}.  It
 implements the RubyGems build procedure used by Ruby packages, which