summary refs log tree commit diff
path: root/emacs/guix-base.el
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2014-11-26 01:32:24 +0300
committerAlex Kost <alezost@gmail.com>2014-12-02 22:09:22 +0300
commit3db349cb09844e2770be3d0dee4e990f1228c2b6 (patch)
treee9bfd03cdb38b69ed4146eae5589a53cd2c7e509 /emacs/guix-base.el
parentece9b4173b3e1d266e6171d3af656fbc93b51a8b (diff)
downloadguix-3db349cb09844e2770be3d0dee4e990f1228c2b6.tar.gz
emacs: Move profiles code to "guix-profiles.el.in".
* emacs/guix-base.el (guix-user-profile, guix-default-profile,
  guix-current-profile, guix-profile-prompt, guix-set-current-profile): Move
  to...
* emacs/guix-init.el.in (guix-default-profile): Move to...
* emacs/guix-profiles.el.in: ... here.  New file.
* configure.ac (AC_CONFIG_FILES): Add "emacs/guix-profiles.el".
* emacs.am (nodist_lisp_DATA): Likewise.
Diffstat (limited to 'emacs/guix-base.el')
-rw-r--r--emacs/guix-base.el42
1 files changed, 1 insertions, 41 deletions
diff --git a/emacs/guix-base.el b/emacs/guix-base.el
index 23575ac2bf..5129c87a5d 100644
--- a/emacs/guix-base.el
+++ b/emacs/guix-base.el
@@ -28,53 +28,13 @@
 ;;; Code:
 
 (require 'cl-lib)
+(require 'guix-profiles)
 (require 'guix-backend)
 (require 'guix-utils)
 (require 'guix-history)
 (require 'guix-messages)
 
 
-;;; Profiles
-
-(defvar guix-user-profile
-  (expand-file-name "~/.guix-profile")
-  "User profile.")
-
-(defvar guix-default-profile
-  (concat (or (getenv "NIX_STATE_DIR") "/var/guix")
-          "/profiles/per-user/"
-          (getenv "USER")
-          "/guix-profile")
-  "Default Guix profile.")
-
-(defvar guix-current-profile guix-default-profile
-  "Current profile.")
-
-(defun guix-profile-prompt (&optional default)
-  "Prompt for profile and return it.
-Use DEFAULT as a start directory.  If it is nil, use
-`guix-current-profile'."
-  (let* ((path (read-file-name "Profile: "
-                               (file-name-directory
-                                (or default guix-current-profile))))
-         (path (directory-file-name (expand-file-name path))))
-    (if (string= path guix-user-profile)
-        guix-default-profile
-      path)))
-
-(defun guix-set-current-profile (path)
-  "Set `guix-current-profile' to PATH.
-Interactively, prompt for PATH.  With prefix, use
-`guix-default-profile'."
-  (interactive
-   (list (if current-prefix-arg
-             guix-default-profile
-           (guix-profile-prompt))))
-  (setq guix-current-profile path)
-  (message "Current profile has been set to '%s'."
-           guix-current-profile))
-
-
 ;;; Parameters of the entries
 
 (defvar guix-param-titles