summary refs log tree commit diff
path: root/emacs/guix-external.el
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2015-10-16 20:34:32 +0300
committerAlex Kost <alezost@gmail.com>2015-10-20 16:47:05 +0300
commit51805219a53311fc56e291b5762860062ef28446 (patch)
treec2cebd782b7824a4c08de343788dfdf071c23eac /emacs/guix-external.el
parentcbe9505778088643684a8942114baa0fcf3b3339 (diff)
downloadguix-51805219a53311fc56e291b5762860062ef28446.tar.gz
build: Set DOT_USER_PROGRAM for Emacs interface.
Suggested by Ludovic Courtès <ludo@gnu.org>.

* configure.ac: Set DOT_USER_PROGRAM variable.
* emacs/guix-config.el.in (guix-config-dot-program): New constant.
* emacs/guix-external.el (guix-dot-program): Use it.
Diffstat (limited to 'emacs/guix-external.el')
-rw-r--r--emacs/guix-external.el7
1 files changed, 6 insertions, 1 deletions
diff --git a/emacs/guix-external.el b/emacs/guix-external.el
index 580676ef91..cf4bd26ac7 100644
--- a/emacs/guix-external.el
+++ b/emacs/guix-external.el
@@ -23,11 +23,16 @@
 
 ;;; Code:
 
+(require 'guix-config)
+
 (defgroup guix-external nil
   "Settings for external programs."
   :group 'guix)
 
-(defcustom guix-dot-program (executable-find "dot")
+(defcustom guix-dot-program
+  (if (file-name-absolute-p guix-config-dot-program)
+      guix-config-dot-program
+    (executable-find "dot"))
   "Name of the 'dot' executable."
   :type 'string
   :group 'guix-external)