summary refs log tree commit diff
path: root/etc
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2024-01-25 11:52:06 -0600
committerTimothy Sample <samplet@ngyro.com>2024-02-12 21:26:01 -0600
commit5f86eebd240958001ab4f178005f355d24d9b7f1 (patch)
treef8954830069793b0d425d5a276577c8e145019bd /etc
parent94c0eeea49b2a9c6ace3b77686dbd17091ce2f2d (diff)
downloadguix-5f86eebd240958001ab4f178005f355d24d9b7f1.tar.gz
gnu: disarchive: Update to 0.6.0.
* gnu/packages/backup.scm (disarchive): Update to 0.6.0; add
'guile-bzip2' as an input.
* gnu/packages/package-management.scm (guix): Add 'guile-bzip2' as
an input to enable bzip2 support when using Disarchive.
* guix/self.scm (%packages): Add 'guile-bzip2'.
(compiled-guix): Include 'guile-bzip2' as a dependency when building
the 'guix' command.
* etc/disarchive-manifest.scm (tarball-origin?): Include bzip2
tarballs.

Co-authored-by: Ludovic Courtès <ludovic.courtes@inria.fr>
Change-Id: I4da479054f6bef225f5ea979c091152f8a9e51d5
Diffstat (limited to 'etc')
-rw-r--r--etc/disarchive-manifest.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/etc/disarchive-manifest.scm b/etc/disarchive-manifest.scm
index 41f64eae4f..3dbfa356df 100644
--- a/etc/disarchive-manifest.scm
+++ b/etc/disarchive-manifest.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2021-2023 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2021-2024 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -35,6 +35,8 @@
      (and (origin-hash origin)
           (or (string-suffix? ".tar.gz" file)
               (string-suffix? ".tgz" file)
+              (string-suffix? ".tar.bz2" file)
+              (string-suffix? ".tbz2" file)
               (string-suffix? ".tar.xz" file)
               (string-suffix? ".tar" file))))))