summary refs log tree commit diff
path: root/gnu/build
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-04-16 16:11:23 +0200
committerLudovic Courtès <ludo@gnu.org>2022-05-01 21:30:35 +0200
commit3682bd4003f4c4e313498931c471eeae2efe09b8 (patch)
tree74754454cf4636592d9e46f06381ab32b0bfa9f6 /gnu/build
parent391bd143592241a5bf3555918a5188c789c1c771 (diff)
downloadguix-3682bd4003f4c4e313498931c471eeae2efe09b8.tar.gz
Add (guix least-authority).
* guix/least-authority.scm: New file.
* Makefile.am (MODULES): Add it.
* gnu/build/shepherd.scm (default-mounts): Make public.
Diffstat (limited to 'gnu/build')
-rw-r--r--gnu/build/shepherd.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/build/shepherd.scm b/gnu/build/shepherd.scm
index d52e53eb78..f4caefce3c 100644
--- a/gnu/build/shepherd.scm
+++ b/gnu/build/shepherd.scm
@@ -31,7 +31,8 @@
                                  exec-command
                                  %precious-signals)
   #:autoload (shepherd system) (unblock-signals)
-  #:export (make-forkexec-constructor/container
+  #:export (default-mounts
+            make-forkexec-constructor/container
             fork+exec-command/container))
 
 ;;; Commentary: