summary refs log tree commit diff
path: root/gnu/build
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-19 16:25:13 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-19 17:28:31 +0100
commit162a13740041f907f0ce5c2aa05b52b162b4e81a (patch)
tree33dc83f44d28063b4262e4f3477061407192c58e /gnu/build
parent28f6f22912ccbdbd485888c59ea263b8581027db (diff)
downloadguix-162a13740041f907f0ce5c2aa05b52b162b4e81a.tar.gz
gnu: Consistently Write ‘file system(s)’.
It is the GNU way.

* doc/guix.texi (Build Systems, DNS Services): Write ‘file system(s)’.
* gnu/build/vm.scm (create-ext-file-system, create-fat-file-system):
Likewise.
* gnu/packages/backup.scm (dirvish, rsnapshot)[description]: Likewise.
* gnu/packages/check.scm (python-testpath)[description]: Likewise.
* gnu/packages/disk.scm (pydf)[description]: Likewise.
* gnu/packages/file-systems.scm (disorderfs)[synopsis, description]: Likewise.
(glusterfs)[description]: Likewise.
* gnu/packages/haskell.scm (ghc-directory, ghc-system-fileio-bootstrap)
(ghc-system-fileio)[synopsis]: Likewise.
(ghc-fsnotify)[description]: Likewise.
* gnu/packages/linux.scm (proot)[description]: Likewise.
(jmtpfs)[synopsis, description]: Likewise.
* gnu/packages/mate.scm (caja, caja-extensions)[description]: Likewise.
* gnu/packages/storage.scm (ceph)[description]: Likewise.
* gnu/packages/sync.scm (lsyncd)[description]: Likewise.
* gnu/packages/syncthing.scm (syncthing)[synopsis]: Likewise.
(go-github-com-zillode-notify)[description]: Likewise.
* gnu/services/nfs.scm (pipefs-service-type): Likewise.
* guix/scripts/system.scm (perform-action): Likewise.
Diffstat (limited to 'gnu/build')
-rw-r--r--gnu/build/file-systems.scm4
-rw-r--r--gnu/build/linux-boot.scm2
-rw-r--r--gnu/build/vm.scm8
3 files changed, 7 insertions, 7 deletions
diff --git a/gnu/build/file-systems.scm b/gnu/build/file-systems.scm
index 3e516a4d3c..145b3b14e7 100644
--- a/gnu/build/file-systems.scm
+++ b/gnu/build/file-systems.scm
@@ -261,11 +261,11 @@ volume descriptor from ~s"
   "Return the raw contents of DEVICE's iso9660 primary volume descriptor
 as a bytevector, or #f if DEVICE does not contain an iso9660 file system."
   ;; Start reading at sector 16.
-  ;; Since we are not sure that the device contains an ISO9660 filesystem,
+  ;; Since we are not sure that the device contains an ISO9660 file system,
   ;; we have to find that out first.
   (if (read-superblock device (* 2048 16) 2048 iso9660-superblock?)
       (read-iso9660-primary-volume-descriptor device (* 2048 16))
-      #f)) ; Device does not contain an iso9660 filesystem.
+      #f)) ; Device does not contain an iso9660 file system.
 
 (define (iso9660-superblock-uuid sblock)
   "Return the modification time of an iso9660 primary volume descriptor
diff --git a/gnu/build/linux-boot.scm b/gnu/build/linux-boot.scm
index 997107a67a..0ab8391b0b 100644
--- a/gnu/build/linux-boot.scm
+++ b/gnu/build/linux-boot.scm
@@ -188,7 +188,7 @@ with the given MAJOR number, starting with MINOR."
     (lambda args
       (apply report-system-error name args))))
 
-;; Create a device node like the <device-node> passed here on the filesystem.
+;; Create a device node like the <device-node> passed here on the file system.
 (define create-device-node
   (match-lambda
     (($ <device-node> xname type major minor module)
diff --git a/gnu/build/vm.scm b/gnu/build/vm.scm
index 404f324045..fe003ea458 100644
--- a/gnu/build/vm.scm
+++ b/gnu/build/vm.scm
@@ -262,7 +262,7 @@ actual /dev name based on DEVICE."
 
 (define* (create-ext-file-system partition type
                                  #:key label uuid)
-  "Create an ext-family filesystem of TYPE on PARTITION.  If LABEL is true,
+  "Create an ext-family file system of TYPE on PARTITION.  If LABEL is true,
 use that as the volume name.  If UUID is true, use it as the partition UUID."
   (format #t "creating ~a partition...\n" type)
   (unless (zero? (apply system* (string-append "mkfs." type)
@@ -277,8 +277,8 @@ use that as the volume name.  If UUID is true, use it as the partition UUID."
 
 (define* (create-fat-file-system partition
                                  #:key label uuid)
-  "Create a FAT filesystem on PARTITION.  The number of File Allocation Tables
-will be determined based on filesystem size.  If LABEL is true, use that as the
+  "Create a FAT file system on PARTITION.  The number of File Allocation Tables
+will be determined based on file system size.  If LABEL is true, use that as the
 volume name."
   ;; FIXME: UUID is ignored!
   (format #t "creating FAT partition...\n")
@@ -425,7 +425,7 @@ GRUB configuration and OS-DRV as the stuff in it."
                             "run=/tmp/root/run"
                             ;; /mnt is used as part of the installation
                             ;; process, as the mount point for the target
-                            ;; filesystem, so create it.
+                            ;; file system, so create it.
                             "mnt=/tmp/root/mnt"
                             "--"
                             "-volid" ,(string-upcase volume-id)