summary refs log tree commit diff
path: root/gnu/installer.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2020-04-08 10:16:25 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2020-04-08 10:24:02 +0200
commit07a53bd512530d8f87e076263227216c467727bb (patch)
treee148fdd21429cea95a39861d536d0cec37984b54 /gnu/installer.scm
parent6e2f7dc5e23f07855da808cf2e4f825680b23d50 (diff)
downloadguix-07a53bd512530d8f87e076263227216c467727bb.tar.gz
installer: Turn help menu into parameters menu.
* gnu/local.mk (INSTALLER_MODULES): Rename help.scm into parameters.scm.
* po/guix/POTFILES.in: Ditto.
* gnu/installer/record.scm (<installer>): Rename help-menu into parameter-menu
and help-page into parameters-page.
* gnu/installer/newt/parameters.scm: Renamed from help.scm. Update information
messages.
* gnu/installer/newt.scm: Update accordingly.
* gnu/installer/newt/keymap.scm: Ditto.
Diffstat (limited to 'gnu/installer.scm')
-rw-r--r--gnu/installer.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/installer.scm b/gnu/installer.scm
index 75c5a01570..6cd3995e51 100644
--- a/gnu/installer.scm
+++ b/gnu/installer.scm
@@ -198,11 +198,11 @@ selected keymap."
         (timezone-data #~(string-append #$tzdata
                                         "/share/zoneinfo/zone.tab")))
     #~(lambda (current-installer)
-        ((installer-help-menu current-installer)
+        ((installer-parameters-menu current-installer)
          (lambda ()
-           ((installer-help-page current-installer)
+           ((installer-parameters-page current-installer)
             (lambda _
-              (#$(compute-keymap-step 'help)
+              (#$(compute-keymap-step 'param)
                current-installer)))))
         (list
          ;; Ask the user to choose a locale among those supported by