summary refs log tree commit diff
path: root/gnu/installer.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-08 13:00:50 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-08 13:00:50 +0200
commit27783023993f9272ce422868d14529159c4a5218 (patch)
tree9013b08aa39e497b1fd8e01a05254278d83f0ff7 /gnu/installer.scm
parentbe1e842ad78ac6c52fc7790f4a3ffd716673c111 (diff)
parentba6f2bda18ed19fa486a9c3e2c3baea6c66c6867 (diff)
downloadguix-27783023993f9272ce422868d14529159c4a5218.tar.gz
Merge branch 'master' into core-updates
 Conflicts:
	etc/news.scm
	gnu/local.mk
	gnu/packages/check.scm
	gnu/packages/cross-base.scm
	gnu/packages/gimp.scm
	gnu/packages/java.scm
	gnu/packages/mail.scm
	gnu/packages/sdl.scm
	gnu/packages/texinfo.scm
	gnu/packages/tls.scm
	gnu/packages/version-control.scm
Diffstat (limited to 'gnu/installer.scm')
-rw-r--r--gnu/installer.scm30
1 files changed, 19 insertions, 11 deletions
diff --git a/gnu/installer.scm b/gnu/installer.scm
index 625b7a9ca4..1060611672 100644
--- a/gnu/installer.scm
+++ b/gnu/installer.scm
@@ -113,8 +113,10 @@ version of this file."
          (setlocale LC_ALL locale))
 
         ;; Restart the documentation viewer so it displays the manual in
-        ;; language that corresponds to LOCALE.
-        (with-error-to-port (%make-void-port "w")
+        ;; language that corresponds to LOCALE.  Make sure that nothing is
+        ;; printed on the console.
+        (parameterize ((shepherd-message-port
+                        (%make-void-port "w")))
           (lambda ()
             (stop-service 'term-tty2)
             (start-service 'term-tty2 (list locale)))))))
@@ -172,7 +174,7 @@ been performed at build time."
        (kmscon-update-keymap (default-keyboard-model)
                              layout variant))))
 
-(define* (compute-keymap-step)
+(define* (compute-keymap-step context)
   "Return a gexp that runs the keymap-page of INSTALLER and install the
 selected keymap."
   #~(lambda (current-installer)
@@ -184,7 +186,7 @@ selected keymap."
                                    "/share/X11/xkb/rules/base.xml")))
                (lambda (models layouts)
                  ((installer-keymap-page current-installer)
-                  layouts)))))
+                  layouts '#$context)))))
         (#$apply-keymap result)
         result)))
 
@@ -193,10 +195,15 @@ selected keymap."
                       #:locales-name "locales"
                       #:iso639-languages-name "iso639-languages"
                       #:iso3166-territories-name "iso3166-territories"))
-        (keymap-step (compute-keymap-step))
         (timezone-data #~(string-append #$tzdata
                                         "/share/zoneinfo/zone.tab")))
     #~(lambda (current-installer)
+        ((installer-parameters-menu current-installer)
+         (lambda ()
+           ((installer-parameters-page current-installer)
+            (lambda _
+              (#$(compute-keymap-step 'param)
+               current-installer)))))
         (list
          ;; Ask the user to choose a locale among those supported by
          ;; the glibc.  Install the selected locale right away, so that
@@ -238,7 +245,8 @@ selected keymap."
           (id 'keymap)
           (description (G_ "Keyboard mapping selection"))
           (compute (lambda _
-                     (#$keymap-step current-installer)))
+                     (#$(compute-keymap-step 'default)
+                      current-installer)))
           (configuration-formatter keyboard-layout->configuration))
 
          ;; Ask the user to input a hostname for the system.
@@ -271,7 +279,7 @@ selected keymap."
           (description (G_ "Services"))
           (compute (lambda _
                      ((installer-services-page current-installer))))
-	  (configuration-formatter system-services->configuration))
+          (configuration-formatter system-services->configuration))
 
          ;; Run a partitioning tool allowing the user to modify
          ;; partition tables, partitions and their mount points.
@@ -284,7 +292,7 @@ selected keymap."
                      ((installer-partition-page current-installer))))
           (configuration-formatter user-partitions->configuration))
 
-	 (installer-step
+         (installer-step
           (id 'final)
           (description (G_ "Configuration file"))
           (compute
@@ -295,8 +303,8 @@ selected keymap."
 (define guile-newt
   ;; Guile-Newt with 'form-watch-fd'.
   ;; TODO: Remove once a new release is out.
-  (let ((commit "b3c885d42cfac327d3531c9d064939514ce6bf12")
-        (revision "1"))
+  (let ((commit "c3cdeb0b53ac71aedabee669f57d44563c662446")
+        (revision "2"))
     (package
       (inherit (@ (gnu packages guile-xyz) guile-newt))
       (name "guile-newt")
@@ -309,7 +317,7 @@ selected keymap."
                  (file-name (git-file-name name version))
                  (sha256
                   (base32
-                   "02p0bi6c05699idgx6gfkljhqgi8zf09clhzx81i8wa064s70r1y")))))))
+                   "1gksd1lzgjjh1p9vczghg8jw995d22hm34kbsiv8rcryirv2xy09")))))))
 
 (define (installer-program)
   "Return a file-like object that runs the given INSTALLER."