summary refs log tree commit diff
path: root/gnu/installer/newt.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-11-16 20:43:55 +0900
committerLudovic Courtès <ludo@gnu.org>2019-01-17 14:04:20 +0100
commitd0f3a672dcbdfefd3556b6a21985ff0e35eed3be (patch)
tree6ca7cc2fc874343791a3b555181177be488a3a8a /gnu/installer/newt.scm
parent08af580bde01ffd8e6968b6f9f9eff14c4f9cc5a (diff)
downloadguix-d0f3a672dcbdfefd3556b6a21985ff0e35eed3be.tar.gz
gnu: Add graphical installer support.
* configure.ac: Require that guile-newt is available.
* gnu/installer.scm: New file.
* gnu/installer/aux-files/logo.txt: New file.
* gnu/installer/build-installer.scm: New file.
* gnu/installer/connman.scm: New file.
* gnu/installer/keymap.scm: New file.
* gnu/installer/locale.scm: New file.
* gnu/installer/newt.scm: New file.
* gnu/installer/newt/ethernet.scm: New file.
* gnu/installer/newt/hostname.scm: New file.
* gnu/installer/newt/keymap.scm: New file.
* gnu/installer/newt/locale.scm: New file.
* gnu/installer/newt/menu.scm: New file.
* gnu/installer/newt/network.scm: New file.
* gnu/installer/newt/page.scm: New file.
* gnu/installer/newt/timezone.scm: New file.
* gnu/installer/newt/user.scm: New file.
* gnu/installer/newt/utils.scm: New file.
* gnu/installer/newt/welcome.scm: New file.
* gnu/installer/newt/wifi.scm: New file.
* gnu/installer/steps.scm: New file.
* gnu/installer/timezone.scm: New file.
* gnu/installer/utils.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add previous files.
* gnu/system.scm: Export %root-account.
* gnu/system/install.scm (%installation-services): Use kmscon instead of linux
VT for all tty.
(installation-os)[users]: Add the graphical installer as shell of the root
account.
[packages]: Add font related packages.
* po/guix/POTFILES.in: Add installer files.
Diffstat (limited to 'gnu/installer/newt.scm')
-rw-r--r--gnu/installer/newt.scm102
1 files changed, 102 insertions, 0 deletions
diff --git a/gnu/installer/newt.scm b/gnu/installer/newt.scm
new file mode 100644
index 0000000000..abf752959b
--- /dev/null
+++ b/gnu/installer/newt.scm
@@ -0,0 +1,102 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu installer newt)
+  #:use-module (gnu installer)
+  #:use-module (guix discovery)
+  #:use-module (guix gexp)
+  #:use-module (guix ui)
+  #:export (newt-installer))
+
+(define (modules)
+  (cons '(newt)
+        (map module-name
+             (scheme-modules
+              (dirname (search-path %load-path "guix.scm"))
+              "gnu/installer/newt"
+              #:warn warn-about-load-error))))
+
+(define init
+  #~(begin
+      (newt-init)
+      (clear-screen)
+      (set-screen-size!)))
+
+(define exit
+  #~(begin
+      (newt-finish)))
+
+(define exit-error
+  #~(lambda (key args)
+      (newt-finish)))
+
+(define locale-page
+  #~(lambda* (#:key
+              supported-locales
+              iso639-languages
+              iso3166-territories)
+      (run-locale-page
+       #:supported-locales supported-locales
+       #:iso639-languages iso639-languages
+       #:iso3166-territories iso3166-territories)))
+
+(define timezone-page
+  #~(lambda* (zonetab)
+      (run-timezone-page zonetab)))
+
+(define logo
+  (string-append
+   (dirname (search-path %load-path "guix.scm"))
+   "/gnu/installer/aux-files/logo.txt"))
+
+(define welcome-page
+  #~(run-welcome-page #$(local-file logo)))
+
+(define menu-page
+  #~(lambda (steps)
+      (run-menu-page steps)))
+
+(define keymap-page
+  #~(lambda* (#:key models layouts)
+      (run-keymap-page #:models models
+                       #:layouts layouts)))
+
+(define network-page
+  #~(run-network-page))
+
+(define hostname-page
+  #~(run-hostname-page))
+
+(define user-page
+  #~(run-user-page))
+
+(define newt-installer
+  (installer
+   (name 'newt)
+   (modules (modules))
+   (init init)
+   (exit exit)
+   (exit-error exit-error)
+   (keymap-page keymap-page)
+   (locale-page locale-page)
+   (menu-page menu-page)
+   (network-page network-page)
+   (timezone-page timezone-page)
+   (hostname-page hostname-page)
+   (user-page user-page)
+   (welcome-page welcome-page)))