summary refs log tree commit diff
path: root/gnu/installer/newt/help.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2020-03-30 12:24:56 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2020-04-06 15:06:03 +0200
commit786c9c39bc0826737e99f0c750ea30033cdbc202 (patch)
treefbcd5bc021f312a2fed88013a1a526c6d0458c92 /gnu/installer/newt/help.scm
parenta274bba2f939ae6637ec613bd0537ba415945835 (diff)
downloadguix-786c9c39bc0826737e99f0c750ea30033cdbc202.tar.gz
installer: Add a help page.
* gnu/installer/newt/help.scm: New file.
* gnu/local.mk (INSTALLER_MODULES): Add it.
* po/guix/POTFILES.in: Add it.
* gnu/installer/record.scm (<installer>): Add 'help-menu' and 'help-page'
 fields,
 (installer-help-menu, installer-help-page): new exported procedures.
 * gnu/installer/newt.scm (init): Set the help line,
 (help-menu, help-page): new procedures used ...
 (newt-installer): ... here.
 * gnu/installer/newt/keymap.scm (run-layout-page): Add a context argument to
 differenciate the help context from the main one,
 (run-keymap-page): add a context argument and pass it to run-layout-page.
 * gnu/installer.scm (compute-keymap-step): Add a context argument and pass it
 to 'installer-keymap-page',
 (installer-steps): set the help menu and pass the appropriate context to
 compute-keymap-step calls,
 (guile-newt): update to revision 2.
Diffstat (limited to 'gnu/installer/newt/help.scm')
-rw-r--r--gnu/installer/newt/help.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/installer/newt/help.scm b/gnu/installer/newt/help.scm
new file mode 100644
index 0000000000..8d85832dc8
--- /dev/null
+++ b/gnu/installer/newt/help.scm
@@ -0,0 +1,43 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu installer newt help)
+  #:use-module (gnu installer steps)
+  #:use-module (gnu installer newt page)
+  #:use-module (guix i18n)
+  #:use-module (ice-9 match)
+  #:use-module (newt)
+  #:export (run-help-page))
+
+(define (run-help-page keyboard-layout-selection)
+  "Run a help page allowing to change the keyboard layout"
+  (let* ((items
+          (list
+           (cons (G_ "Change keyboard layout") keyboard-layout-selection)))
+         (result
+          (run-listbox-selection-page
+           #:info-text (G_ "This is the help menu, please choose an action.")
+           #:title (G_ "Installation help")
+           #:listbox-items items
+           #:listbox-item->text car
+           #:sort-listbox-items? #f
+           #:button-text (G_ "Continue"))))
+    (match result
+      ((_ . proc)
+       (proc))
+      (_ #f))))