summary refs log tree commit diff
path: root/gnu/installer/record.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-12-05 14:57:28 +0900
committerLudovic Courtès <ludo@gnu.org>2019-01-17 14:04:24 +0100
commit69a934f23ae1bd7dda9ec269a6ce3012e13c9011 (patch)
tree676284660aa7c1f29d5379bbb17b84d627a10fcf /gnu/installer/record.scm
parent47c94801656c7e9ddf1dcfe0189b48d7c57d0a1d (diff)
downloadguix-69a934f23ae1bd7dda9ec269a6ce3012e13c9011.tar.gz
installer: Add partitioning support.
* gnu/installer.scm (installer-steps): Add partitioning step.
* gnu/installer/newt.scm (newt-installer): Add partition-page field.
* gnu/installer/newt/partition.scm: New file.
* gnu/installer/parted.scm: New file.
* gnu/installer/record (installer): New partition-page field.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add new files.
* po/guix/POTFILES.in: Add new files.
Diffstat (limited to 'gnu/installer/record.scm')
-rw-r--r--gnu/installer/record.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/installer/record.scm b/gnu/installer/record.scm
index 3ef0a101d3..edf73b6215 100644
--- a/gnu/installer/record.scm
+++ b/gnu/installer/record.scm
@@ -35,6 +35,7 @@
             installer-timezone-page
             installer-hostname-page
             installer-user-page
+            installer-partition-page
             installer-services-page
             installer-welcome-page))
 
@@ -76,6 +77,8 @@
   ;; procedure void -> void
   (user-page installer-user-page)
   ;; procedure void -> void
+  (partition-page installer-partition-page)
+  ;; procedure void -> void
   (services-page installer-services-page)
   ;; procedure (logo) -> void
   (welcome-page installer-welcome-page))