summary refs log tree commit diff
path: root/gnu/installer
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2020-04-08 10:20:33 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2020-04-08 10:24:02 +0200
commitee0ad7803c82383ac1bced073d8670bc407797e7 (patch)
tree8fe5f367737013bb6262a32182971a123b72af1c /gnu/installer
parent07a53bd512530d8f87e076263227216c467727bb (diff)
downloadguix-ee0ad7803c82383ac1bced073d8670bc407797e7.tar.gz
installer: Add proxy support.
* gnu/installer/proxy.scm: New file.
* gnu/local.mk (INSTALLER_MODULES): Add it.
* po/guix/POTFILES.in: Add it.
* gnu/installer/newt/parameters.scm (run-proxy-page): New procedure,
(run-parameters-page): add the previous procedure to the parameters menu.
Diffstat (limited to 'gnu/installer')
-rw-r--r--gnu/installer/newt/parameters.scm14
-rw-r--r--gnu/installer/proxy.scm45
2 files changed, 58 insertions, 1 deletions
diff --git a/gnu/installer/newt/parameters.scm b/gnu/installer/newt/parameters.scm
index 4a34e94155..95112b5780 100644
--- a/gnu/installer/newt/parameters.scm
+++ b/gnu/installer/newt/parameters.scm
@@ -17,6 +17,7 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu installer newt parameters)
+  #:use-module (gnu installer proxy)
   #:use-module (gnu installer steps)
   #:use-module (gnu installer newt page)
   #:use-module (guix i18n)
@@ -24,11 +25,22 @@
   #:use-module (newt)
   #:export (run-parameters-page))
 
+(define (run-proxy-page)
+  (define proxy
+    (run-input-page (G_ "Please enter the HTTP proxy URL. If you enter an \
+empty string, proxy usage will be disabled.")
+                    (G_ "HTTP proxy configuration")
+                    #:allow-empty-input? #t))
+  (if (string=? proxy "")
+      (clear-http-proxy)
+      (set-http-proxy proxy)))
+
 (define (run-parameters-page keyboard-layout-selection)
   "Run a parameters page allowing to change the keyboard layout"
   (let* ((items
           (list
-           (cons (G_ "Change keyboard layout") keyboard-layout-selection)))
+           (cons (G_ "Change keyboard layout") keyboard-layout-selection)
+           (cons (G_ "Configure HTTP proxy") run-proxy-page)))
          (result
           (run-listbox-selection-page
            #:info-text (G_ "Please choose one of the following parameters or \
diff --git a/gnu/installer/proxy.scm b/gnu/installer/proxy.scm
new file mode 100644
index 0000000000..befaf3ab0a
--- /dev/null
+++ b/gnu/installer/proxy.scm
@@ -0,0 +1,45 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu installer proxy)
+  #:use-module (gnu services herd)
+  #:export (set-http-proxy
+            clear-http-proxy))
+
+(define-syntax-rule (with-silent-shepherd exp ...)
+  (parameterize ((shepherd-message-port
+                  (%make-void-port "w")))
+    exp ...))
+
+(define (set-http-proxy proxy)
+  (with-silent-shepherd
+    (with-shepherd-action 'guix-daemon
+        ('set-http-proxy proxy)
+        result
+      result)))
+
+(define (clear-http-proxy)
+  (with-silent-shepherd
+    (with-shepherd-action 'guix-daemon
+        ('set-http-proxy)
+        result
+      result)))
+
+;; Local Variables:
+;; eval: (put 'with-silent-shepherd 'scheme-indent-function 0)
+;; End: