summary refs log tree commit diff
path: root/gnu/local.mk
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-11-24 12:25:03 +0900
committerLudovic Courtès <ludo@gnu.org>2019-01-17 14:04:21 +0100
commita49d633c0c65975263270f5ac0050482ca6a5513 (patch)
tree362e0df559e06cacb31b04fd384344ef789ef0dc /gnu/local.mk
parent113bdf6ae1819022d8c0d640b78a37c7d6b52723 (diff)
downloadguix-a49d633c0c65975263270f5ac0050482ca6a5513.tar.gz
installer: Move everything to the build side.
* gnu/installer.scm: Rename to ...
* gnu/installer/record.scm: ... this.
* gnu/installer/build-installer.scm: Move everything to the build side and
rename to gnu/installer.scm.
* gnu/installer/newt.scm: Remove all the gexps and add depencies to newt
modules as this code will only be used on the build side by now.
* gnu/local.mk (GNU_SYSTEM_MODULES): Adapt it,
(dist_installer_DATA): New rule to install installer's aux-files.
* gnu/system/install.scm (%installation-services): Use only
'installer-program' from (gnu installer). The installer is now choosen on the
build side.
* guix/self.scm (*system-modules*): Restore previous behaviour and add all
installer files to #:extra-files field of the scheme-node.
* po/guix/POTFILES.in: Adapt it.
Diffstat (limited to 'gnu/local.mk')
-rw-r--r--gnu/local.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 665721bec1..b0ec16de34 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -567,7 +567,7 @@ if ENABLE_INSTALLER
 
 GNU_SYSTEM_MODULES +=                           \
   %D%/installer.scm      			\
-  %D%/installer/build-installer.scm		\
+  %D%/installer/record.scm		        \
   %D%/installer/connman.scm			\
   %D%/installer/keymap.scm			\
   %D%/installer/locale.scm			\
@@ -588,6 +588,11 @@ GNU_SYSTEM_MODULES +=                           \
   %D%/installer/newt/welcome.scm		\
   %D%/installer/newt/wifi.scm	
 
+installerdir = $(guilemoduledir)/%D%/installer
+dist_installer_DATA =				\
+  %D%/installer/aux-files/logo.txt	        \
+  %D%/installer/aux-files/SUPPORTED
+
 endif ENABLE_INSTALLER
 
 # Modules that do not need to be compiled.