summary refs log tree commit diff
path: root/gnu/packages.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-11-21 23:51:59 +0100
committerLudovic Courtès <ludo@gnu.org>2017-11-21 23:53:10 +0100
commitcd295fbe170a93844f9c42cbfaa0fbe2490b6693 (patch)
tree869aefd211aa91b857619755b3ee9e8ab5c71f6e /gnu/packages.scm
parentaa33cc29cae391d4208c8a4d879c82025ea4e86c (diff)
downloadguix-cd295fbe170a93844f9c42cbfaa0fbe2490b6693.tar.gz
Revert "Add (guix self) and use it when pulling."
This reverts commit 5f93d97005897c2d859f0be1bdff34c88467ec61.

'guix pull' would fail because (guix self) needs 'scheme-files'
from (guix discovery), which was not exported until now.
Diffstat (limited to 'gnu/packages.scm')
-rw-r--r--gnu/packages.scm21
1 files changed, 2 insertions, 19 deletions
diff --git a/gnu/packages.scm b/gnu/packages.scm
index 44a56dfde0..97e6cb347f 100644
--- a/gnu/packages.scm
+++ b/gnu/packages.scm
@@ -110,25 +110,8 @@ for system '~a'")
                         file-name system)))))))
 
 (define %distro-root-directory
-  ;; Absolute file name of the module hierarchy.  Since (gnu packages …) might
-  ;; live in a directory different from (guix), try to get the best match.
-  (letrec-syntax ((dirname* (syntax-rules ()
-                              ((_ file)
-                               (dirname file))
-                              ((_ file head tail ...)
-                               (dirname (dirname* file tail ...)))))
-                  (try      (syntax-rules ()
-                              ((_ (file things ...) rest ...)
-                               (match (search-path %load-path file)
-                                 (#f
-                                  (try rest ...))
-                                 (absolute
-                                  (dirname* absolute things ...))))
-                              ((_)
-                               #f))))
-    (try ("gnu/packages/base.scm" gnu/ packages/)
-         ("gnu/packages.scm"      gnu/)
-         ("guix.scm"))))
+  ;; Absolute file name of the module hierarchy.
+  (dirname (search-path %load-path "guix.scm")))
 
 (define %package-module-path
   ;; Search path for package modules.  Each item must be either a directory