summary refs log tree commit diff
path: root/gnu/packages/abiword.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-03-05 23:13:36 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-03-05 23:42:28 +0100
commitdbd085ff5f91824a6c396fc88fd71c856af810d2 (patch)
tree9469086e3f66990caf5e215cbf06c187c5090b99 /gnu/packages/abiword.scm
parenta7790d30857cd2bbfcc8691f7f4b60779459de49 (diff)
downloadguix-dbd085ff5f91824a6c396fc88fd71c856af810d2.tar.gz
gnu: abiword: Enable gobject introspection.
* gnu/packages/abiword.scm (abiword)[native-inputs]: Add gobject-introspection
and python-wrapper.
[arguments]: Enable building of gobject introspection files.
Diffstat (limited to 'gnu/packages/abiword.scm')
-rw-r--r--gnu/packages/abiword.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/abiword.scm b/gnu/packages/abiword.scm
index d97de005d2..1635ed54fd 100644
--- a/gnu/packages/abiword.scm
+++ b/gnu/packages/abiword.scm
@@ -40,6 +40,7 @@
   #:use-module (gnu packages ots)
   #:use-module (gnu packages popt)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages wv)
   #:use-module (gnu packages xml))
@@ -73,7 +74,14 @@
               "latex " "loadbindings " "mht " "mif " "mswrite " "opendocument "
               "openwriter " "openxml " "opml " "ots " "paint " "passepartout "
               "pdb " "pdf " "presentation " "s5 " "sdw " "t602 " "urldict "
-              "wikipedia " "wml " "xslfo"))
+              "wikipedia " "wml " "xslfo")
+          "--enable-introspection"
+          (string-append "--with-gir-dir="
+                         (assoc-ref %outputs "out")
+                         "/share/gir-1.0")
+          (string-append "--with-typelib-dir="
+                         (assoc-ref %outputs "out")
+                         "/lib/girepository-1.0"))
         ;; tests fail with: Gtk-CRITICAL **: gtk_settings_get_for_screen:
         ;;                  assertion 'GDK_IS_SCREEN (screen)' failed
         ;;                  GLib-GObject-CRITICAL **: g_object_get_qdata:
@@ -106,10 +114,12 @@
            wv
            zlib))
     (native-inputs
-     (list intltool
+     (list gobject-introspection
+           intltool
            `(,glib "bin")
            libtool
-           pkg-config))
+           pkg-config
+           python-wrapper))
     (home-page "https://www.abisource.com/")
     (synopsis "Word processing program")