summary refs log tree commit diff
path: root/gnu/packages/ada.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-06-23 17:52:23 +0200
committerLudovic Courtès <ludo@gnu.org>2021-06-29 12:37:31 +0200
commitd284e35196975788be68165ccf1f770a2481d938 (patch)
tree76f01ac1d4cfcd1e3591c278c74a57daa08b9580 /gnu/packages/ada.scm
parent3c1e1ec10783132b108e278e8ca345b1b6f49ca2 (diff)
downloadguix-d284e35196975788be68165ccf1f770a2481d938.tar.gz
gnu: python2-libadalang: Remove package.
* gnu/packages/ada.scm (python2-libadalang): Remove variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/ada.scm')
-rw-r--r--gnu/packages/ada.scm40
1 files changed, 0 insertions, 40 deletions
diff --git a/gnu/packages/ada.scm b/gnu/packages/ada.scm
index d24aa2b168..240e13f3ef 100644
--- a/gnu/packages/ada.scm
+++ b/gnu/packages/ada.scm
@@ -177,43 +177,3 @@ specification in our Python DSL and Langkit will generate for you an
 Ada library with bindings for the C and Python programming languages.")
       (home-page "https://github.com/AdaCore/langkit/")
       (license license:gpl3+))))   ; and gcc runtime library exception
-
-(define-public python2-libadalang
-  (let ((commit "9b205e9bacdd50a68117727332e16fbef5f6ac49")
-        (revision "0"))
-    (package
-      (name "python2-libadalang")
-      (version (git-version "0.0.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/AdaCore/libadalang")
-                      (commit commit)))
-                (sha256
-                 (base32
-                  "06hsnzj2syqpq2yhg1bb0zil7ydbyqkdmkjbf8j9b5sdgkyh5xrp"))
-                (file-name (string-append name "-" version "-checkout"))))
-      (build-system python-build-system)
-      (native-inputs
-       `(("python2-langkit" ,python2-langkit)
-         ("python2-quex" ,python2-quex-0.67.3)))
-      (arguments
-       `(#:python ,python-2
-         #:phases
-         (modify-phases %standard-phases
-           (replace 'build
-             (lambda _
-               (invoke "python2" "ada/manage.py" "generate")
-               (invoke "python2" "ada/manage.py" "build")))
-           (replace 'check
-             (lambda _
-               (invoke "python2" "ada/manage.py" "test")))
-           (replace 'install
-             (lambda* (#:key outputs #:allow-other-keys)
-               (let* ((out (assoc-ref outputs "out")))
-                 (invoke "python2" "ada/manage.py" "install" out)))))))
-      (synopsis "Semantic Analysis for Ada in Python")
-      (description "@code{libadalang} provides a high-performance semantic
-engine for the Ada programming language.")
-      (home-page "https://github.com/AdaCore/libadalang")
-      (license license:gpl3)))) ; and gcc runtime gcc lib exception