summary refs log tree commit diff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-02-11 12:34:51 +0800
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-02-19 08:16:47 +0100
commit28cefd2e560d5db60de7e03978ef03f57dd2011f (patch)
tree60f5a06895c33ea1ce97085ebc85df51fde9f653 /gnu/packages/admin.scm
parent243eb86c6ffa9d0a5665d90e33f788e2aac8dab5 (diff)
downloadguix-28cefd2e560d5db60de7e03978ef03f57dd2011f.tar.gz
gnu: hyfetch: Update to 1.4.6.
* gnu/packages/patches/hyfetch-fix-generator-script-quotation-escaping.patch:
New file.
* gnu/packages/patches/hyfetch-remove-old-catchy-os-py.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add them.
* gnu/packages/admin.scm (hyfetch)[source]: Update to 1.4.6.
Switch to git source and add patches.
[inputs]: Remove python-hypy-utils.
[arguments]<#:phases>: Remove set-HOME phase.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm27
1 files changed, 16 insertions, 11 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 568c6ce650..b79621e279 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3915,19 +3915,24 @@ you are running, what theme or icon set you are using, etc.")
 (define-public hyfetch
   (package
     (name "hyfetch")
-    (version "1.4.4")
+    (version "1.4.6")
     (source
-      (origin
-        (method url-fetch)
-        (uri (pypi-uri "HyFetch" version))
-        (sha256
-          (base32 "1k3pcl16y2czkk7wd79yk0w1kqpi4fp8h8szhjs5ywwy20nqmms8"))))
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/hykilpikonna/hyfetch")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (patches
+        (search-patches
+         ;; XXX: Cherry-picked from upstream, remove when updating.
+         "hyfetch-fix-generator-script-quotation-escaping.patch"
+         "hyfetch-remove-old-catchy-os-py.patch"))
+       (sha256
+        (base32
+         "1cnjvkil40bipia8gvs32q0lbqyi5j0nrsr7k4s0c55rh5bhkc3d"))))
     (build-system python-build-system)
-    (inputs (list python-hypy-utils python-typing-extensions))
-    (arguments `(#:phases (modify-phases %standard-phases
-                            (add-before 'build 'set-HOME
-                              (lambda _  ;; Tries to set files in .config
-                                (setenv "HOME" "/tmp"))))))
+    (inputs (list python-typing-extensions))
     (home-page "https://github.com/hykilpikonna/HyFetch")
     (synopsis "@code{neofetch} with pride flags <3")
     (description "HyFetch is a command-line system information tool fork of