summary refs log tree commit diff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorLuHui <luhux76@gmail.com>2023-02-18 20:32:33 +0800
committerChristopher Baines <mail@cbaines.net>2023-02-21 13:39:41 +0000
commit1461bf96e3bd9492ba3af1c98b6b4bce383af20a (patch)
treeaa4442d929fae68d53c740ad98b20beb59cccae4 /gnu/packages/admin.scm
parente1e74336a2b5f39653520b731bdc3696390a1f18 (diff)
downloadguix-1461bf96e3bd9492ba3af1c98b6b4bce383af20a.tar.gz
gnu: xfel: Update to 1.2.9.
* gnu/packages/admin.scm (xfel): Update to 1.2.9.
[arguments]: Remove udevadm command.
[synopsis,description]: Change D1 computers/devices to just devices as the
capabilities are more general.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index b79621e279..d4cc8ca6ca 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -56,6 +56,7 @@
 ;;; Copyright © 2022, 2023 Matthew James Kraai <kraai@ftbfs.org>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;; Copyright © 2023 Juliana Sims <jtsims@protonmail.com>
+;;; Copyright © 2023 Lu Hui <luhux76@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3740,7 +3741,7 @@ in order to be able to find it.
 (define-public xfel
   (package
     (name "xfel")
-    (version "1.2.4")
+    (version "1.2.9")
     (source
      (origin
        (method git-fetch)
@@ -3748,7 +3749,7 @@ in order to be able to find it.
               (url "https://github.com/xboot/xfel.git")
               (commit (string-append "v" version))))
        (sha256
-         (base32 "0r4j63vh6279fj1yh71h08d1av3nc0majlad5yh6admsxiig101m"))
+         (base32 "0gs37w5zjfmyadm49hdalq6vr6gidc683agz3shncgj93x2hxx02"))
        (file-name (git-file-name name version))))
     (native-inputs
      (list pkg-config))
@@ -3766,12 +3767,14 @@ in order to be able to find it.
                 (("/usr/local") out)
                 (("/usr") out)
                 (("/etc/udev/rules.d")
-                 (string-append out "/lib/udev/rules.d"))))))
+                 (string-append out "/lib/udev/rules.d"))
+                (("udevadm control --reload") ; next version will remove this
+                  "")))))
          (delete 'configure))))
     (home-page "https://github.com/xboot/xfel")
-    (synopsis "Remote debugging tool for Allwinner D1 computers")
-    (description "This package contains a debugging tool for Allwinner D1
-devices (connects via USB OTG).")
+    (synopsis "Remote debugging tool for Allwinner devices")
+    (description "This package contains a debugging tool for Allwinner devices
+(connects via USB OTG).")
     (license license:expat)))
 
 (define-public sedsed