summary refs log tree commit diff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2023-05-24 18:09:48 +0000
committer宋文武 <iyzsong@member.fsf.org>2023-05-26 20:50:39 +0800
commit201df17a60c731781bb8d0a3b7abfbef34e66197 (patch)
treef10df02eb89aeb05125d15090b64f0e70faff728 /gnu/packages/admin.scm
parent60b71b0db4ab690817df78f711cc3267419ad6c0 (diff)
downloadguix-201df17a60c731781bb8d0a3b7abfbef34e66197.tar.gz
gnu: jc: Update to 1.23.2.
* gnu/packages/admin.scm (jc): Update to 1.23.2.
[build-system]: Change to PYPROJECT-BUILD-SYSTEM.
[native-inputs]: Add python-pytest.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 047b0ebcc6..aa6cabee39 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -85,6 +85,7 @@
   #:use-module (guix build-system meson)
   #:use-module (guix build-system perl)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system pyproject)
   #:use-module (guix build-system qt)
   #:use-module (guix build-system ruby)
   #:use-module (guix build-system trivial)
@@ -4822,7 +4823,7 @@ LUKS volumes encrypted with the user's log-in password.")
 (define-public jc
   (package
     (name "jc")
-    (version "1.19.0")
+    (version "1.23.2")
     (source
      (origin
        ;; The PyPI tarball lacks the test suite.
@@ -4832,8 +4833,8 @@ LUKS volumes encrypted with the user's log-in password.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "021zk0y8kb6v3qf3hwfg8qjzzmrca039nz3fjywiy2njmbhr8hyi"))))
-    (build-system python-build-system)
+        (base32 "17g2q0h3jwzfm80ldl8inpyh5y0qzzmgvyg10gkk1rp8i34wfgly"))))
+    (build-system pyproject-build-system)
     (arguments
      (list #:phases
            #~(modify-phases %standard-phases
@@ -4842,6 +4843,7 @@ LUKS volumes encrypted with the user's log-in password.")
                  (lambda _
                    (substitute* (find-files "tests" "^test.*\\.py$")
                      (("America/Los_Angeles") "PST8PDT")))))))
+    (native-inputs (list python-pytest))
     (propagated-inputs
      (list python-pygments python-ruamel.yaml python-xmltodict))
     (home-page "https://github.com/kellyjonbrazil/jc")