summary refs log tree commit diff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-07-05 17:34:05 +0100
committerLudovic Courtès <ludo@gnu.org>2023-07-18 00:41:15 +0200
commitbdcf1de75621f443553b68d7ae1b99a020cf6bac (patch)
treec886a58e16d9819448bc5d8355f924c53cda5dc1 /gnu/packages/admin.scm
parent460b2afeb39733ee8d2730b35192c97630fc2a10 (diff)
downloadguix-bdcf1de75621f443553b68d7ae1b99a020cf6bac.tar.gz
gnu: mactelnet: Unbundle uthash.
* gnu/packages/admin.scm (mactelnet)[source]: Unbundle uthash.
[inputs]: Add uthash.
[license]: Remove bsd-2.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index f2378b0d8a..ec32041055 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -114,6 +114,7 @@
   #:use-module (gnu packages cryptsetup)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages cyrus-sasl)
+  #:use-module (gnu packages datastructures)
   #:use-module (gnu packages dns)
   #:use-module (gnu packages elf)
   #:use-module (gnu packages file)
@@ -5867,12 +5868,19 @@ text mode.")
               (sha256
                (base32
                 "1z63dz22crrvrm0sh2cwpyqb7wqd9m45m6f2641mwmyp6hcpf4k4"))
-              (patches (search-patches "mactelnet-remove-init.patch"))))
+              (patches (search-patches "mactelnet-remove-init.patch"))
+              (modules '((guix build utils)))
+              (snippet
+               #~(begin
+                   (delete-file "src/utlist.h")
+                   (substitute* (find-files "src/" "\\.c$")
+                     (("\"utlist\\.h\"") "<utlist.h>"))))))
     (build-system gnu-build-system)
     (arguments
      (list
       #:tests? #f))  ; no tests
     (native-inputs (list autoconf automake gettext-minimal))
+    (inputs (list uthash))
     (synopsis "MAC-Telnet utilities for communicating with RouterOS devices")
     (description "This package provides an implementation of the MAC-Telnet protocol
 used by RouterOS devices.  It provides the following commands:
@@ -5891,6 +5899,4 @@ Discover other RouterOS devices or @command{mactelnetd} hosts.
      (list license:gpl2+
            ;; Note: applies to src/md5.{c,h}
            ;; This file is likely to be gone in the next release.
-           license:zlib
-           ;; Bundled uthash-1.9.9.
-           license:bsd-2))))
+           license:zlib))))