summary refs log tree commit diff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-12-23 10:41:22 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-08 23:51:01 +0100
commit43eb601f76b167f487a819c2ad4b01b0f9c29dab (patch)
treed8d9f66721664c2a4e50fc0e6bdc302a2a10f19e /gnu/packages/admin.scm
parentecb589227cc3867dc4a695a39d1417a72def0f4b (diff)
downloadguix-43eb601f76b167f487a819c2ad4b01b0f9c29dab.tar.gz
gnu: sunxi-tools: Don't use unstable tarball.
* gnu/packages/admin.scm (sunxi-tools)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 721d2c15e3..f6b70ca6db 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2206,11 +2206,12 @@ Kerberos and Heimdal and FAST is supported with recent MIT Kerberos.")
     (version "1.4.2")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/linux-sunxi/"
-                           "sunxi-tools/archive/v" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/linux-sunxi/sunxi-tools.git")
+             (commit (string-append "v" version))))
        (sha256
-        (base32 "08iqwj95qw2s7ilhrdi2lkbc8dx64zk5lzz1qk587jr0lla81x41"))
+        (base32 "04f3jqg8ww4jxsf9c6ddcdgy2xbhkyp0b3l5f1hvvbv94p81rjxd"))
        (modules '((guix build utils)))
        (snippet
         ;; Remove binaries contained in the tarball which are only for the
@@ -2218,7 +2219,7 @@ Kerberos and Heimdal and FAST is supported with recent MIT Kerberos.")
         '(begin
            (delete-file-recursively "bin")
            #t))
-       (file-name (string-append name "-" version ".tar.gz"))))
+       (file-name (git-file-name name version))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("cross-gcc" ,(cross-gcc "arm-linux-gnueabihf"