summary refs log tree commit diff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-11-07 15:29:06 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2016-11-22 01:12:03 +0100
commiteec9c4a7c5615698254357b7fa0bcbeeb0137cbc (patch)
treea35fee60e6141588446b684e9a0d9bedfe1669d5 /gnu/packages/admin.scm
parent57742b35dc0260ad8779438273cccce5f3d6e2c0 (diff)
downloadguix-eec9c4a7c5615698254357b7fa0bcbeeb0137cbc.tar.gz
gnu: progress: Update to 0.13.1.
* gnu/packages/admin.scm (progress): Update to 0.13.1.
[native-inputs]: Add pkg-config and which.
[arguments]: Drop LDFLAGS (now handled by pkg-config) from #:make-flags.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5adde6cc4a..88d9cdc21b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -112,20 +112,23 @@ usual file attributes can be checked for inconsistencies.")
 (define-public progress
   (package
     (name "progress")
-    (version "0.13")
+    (version "0.13.1")
     (source (origin
       (method url-fetch)
       (uri (string-append "https://github.com/Xfennec/"
                           name "/archive/v" version ".tar.gz"))
       (sha256
-       (base32 "133iar4vq5vlklydb4cyazjy6slmpbndrws474mg738bd8avc30n"))
+       (base32 "199rk6608q9m6l0fbjm0xl2w1c5krf8245dqnksdp4rqp7l9ak06"))
       (file-name (string-append name "-" version ".tar.gz"))))
     (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("which" ,which)))
     (inputs
      `(("ncurses" ,ncurses)))
     (arguments
      `(#:tests? #f ; There is no test suite.
-       #:make-flags (list "CC=gcc" "LDFLAGS+=-lncurses"
+       #:make-flags (list "CC=gcc"
                           (string-append "PREFIX=" (assoc-ref %outputs "out")))
        #:phases
        (modify-phases %standard-phases