summary refs log tree commit diff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-10-05 04:08:46 +0100
committerLeo Famulari <leo@famulari.name>2016-10-09 17:37:36 -0400
commitfc0081213d612dc0b4f5f90d5b775704511a7432 (patch)
tree3cce73b98b2d001e878d740f20b3e12951928c75 /gnu/packages/admin.scm
parent6f9d5b2e8c861c3a1243937a26400f8394946346 (diff)
downloadguix-fc0081213d612dc0b4f5f90d5b775704511a7432.tar.gz
gnu: wpa-supplicant: Update to 2.6.
* gnu/packages/admin.scm (wpa-supplicant-minimal)[source]: Update to
  2.6. Remove 'patches' field.
* gnu/packages/patches/wpa-supplicant-CVE-2015-5310.patch,
  gnu/packages/patches/wpa-supplicant-CVE-2015-5314.patch,
  gnu/packages/patches/wpa-supplicant-CVE-2015-5315.patch,
  gnu/packages/patches/wpa-supplicant-CVE-2015-5316.patch,
  gnu/packages/patches/wpa-supplicant-CVE-2016-4476.patch,
  gnu/packages/patches/wpa-supplicant-CVE-2016-4477-pt1.patch,
  gnu/packages/patches/wpa-supplicant-CVE-2016-4477-pt2.patch,
  gnu/packages/patches/wpa-supplicant-CVE-2016-4477-pt3.patch,
  gnu/packages/patches/wpa-supplicant-CVE-2016-4477-pt4.patch: Delete
  files.
* gnu/local.mk (dist_patch_DATA): Remove them.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm14
1 files changed, 2 insertions, 12 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index cfb33c40c3..d9b08efc4c 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -862,7 +862,7 @@ commands and their arguments.")
 (define-public wpa-supplicant-minimal
   (package
     (name "wpa-supplicant-minimal")
-    (version "2.5")
+    (version "2.6")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -871,17 +871,7 @@ commands and their arguments.")
                     ".tar.gz"))
               (sha256
                (base32
-                "05mkp5bx1c3z7h5biddsv0p49gkrq9ksany3anp4wdiv92p5prfc"))
-              (patches
-               (search-patches "wpa-supplicant-CVE-2015-5310.patch"
-                               "wpa-supplicant-CVE-2015-5314.patch"
-                               "wpa-supplicant-CVE-2015-5315.patch"
-                               "wpa-supplicant-CVE-2015-5316.patch"
-                               "wpa-supplicant-CVE-2016-4476.patch"
-                               "wpa-supplicant-CVE-2016-4477-pt1.patch"
-                               "wpa-supplicant-CVE-2016-4477-pt2.patch"
-                               "wpa-supplicant-CVE-2016-4477-pt3.patch"
-                               "wpa-supplicant-CVE-2016-4477-pt4.patch"))))
+                "0l0l5gz3d5j9bqjsbjlfcv4w4jwndllp9fmyai4x9kg6qhs6v4xl"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases (alist-replace