summary refs log tree commit diff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-07-25 17:47:53 +0200
committerLudovic Courtès <ludo@gnu.org>2014-07-25 17:48:06 +0200
commitd43f4296ccdf4587266c88a7c3e116e720eaddd0 (patch)
tree32e956c16d422a605576ff0a33a2b9512c391d2c /gnu/packages/admin.scm
parent5e6feee61793a6b60aa352dcdbbed0155eb42e7f (diff)
downloadguix-d43f4296ccdf4587266c88a7c3e116e720eaddd0.tar.gz
gnu: Add dmidecode.
* gnu/packages/admin.scm (dmidecode): New variable.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 9fef60d761..46f5cc8a58 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -762,3 +762,33 @@ This package provides the 'wpa_supplicant' daemon and the 'wpa_cli' command.")
      "WakeLan broadcasts a properly formatted UDP packet across the local area
 network, which causes enabled computers to power on.")
     (license gpl2+)))
+
+(define-public dmidecode
+  (package
+    (name "dmidecode")
+    (version "2.12")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://savannah/dmidecode/dmidecode-"
+                    version ".tar.bz2"))
+              (sha256
+               (base32
+                "122hgaw8mpqdfra159lfl6pyk3837giqx6vq42j64fjnbl2z6gwi"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases (alist-delete 'configure %standard-phases)
+       #:tests? #f                                ; no 'check' target
+       #:make-flags (list (string-append "prefix="
+                                         (assoc-ref %outputs "out")))))
+    (home-page "http://www.nongnu.org/dmidecode/")
+    (synopsis "Read hardware information from the BIOS")
+    (description
+     "Dmidecode reports information about your system's hardware as described
+in your system BIOS according to the SMBIOS/DMI standard.  This typically
+includes system manufacturer, model name, serial number, BIOS version, asset
+tag as well as a lot of other details of varying level of interest and
+reliability depending on the manufacturer.  This will often include usage
+status for the CPU sockets, expansion slots (e.g. AGP, PCI, ISA) and memory
+module slots, and the list of I/O ports (e.g. serial, parallel, USB).")
+    (license gpl2+)))