summary refs log tree commit diff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorPeter <peter.feigl@nexoid.at>2016-06-10 12:11:21 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-10 15:21:26 +0200
commit1a0346f0601481472794f0ffa47137416999bde9 (patch)
tree42b4de0755141f6bec8a79186f53456b61279053 /gnu/packages/admin.scm
parent0ee23de941537f1efdc0271aa4b0b721318989f1 (diff)
downloadguix-1a0346f0601481472794f0ffa47137416999bde9.tar.gz
gnu: Add dstat.
* gnu/packages/admin.scm (dstat): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index abfef36660..81ca58d8f5 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -10,6 +10,7 @@
 ;;; Copyright © 2016 Pjotr Prins <pjotr.guix@thebird.nl>
 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Peter Feigl <peter.feigl@nexoid.at>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -58,6 +59,7 @@
   #:use-module (gnu packages mcrypt)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages popt)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages groff)
   #:use-module (gnu packages pciutils)
@@ -1643,3 +1645,39 @@ results (ndiff), and a packet generation and response analysis tool (nping).")
     ;; This package uses nmap's bundled versions of libdnet and liblinear, which
     ;; both use a 3-clause BSD license.
     (license (list license:nmap license:bsd-3))))
+
+(define-public dstat
+  (package
+    (name "dstat")
+    (version "0.7.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/dagwieers/dstat/archive/"
+                    version ".tar.gz"))
+              (file-name (string-append "dstat-" version ".tar.gz"))
+              (sha256
+               (base32
+                "16286z3y2lc9nsq8njzjkv6k2vyxrj9xiixj1k3gnsbvhlhkirj6"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ;; no make check
+       #:make-flags (let ((out (assoc-ref %outputs "out")))
+                      (list (string-append "DESTDIR=" out)
+                            "prefix=/"))
+       ;; no configure script
+       #:phases (alist-delete 'configure %standard-phases)))
+    (inputs `(("python-2" ,python-2)))
+    (synopsis "Versatile resource statistics tool")
+    (description "Dstat is a versatile replacement for @command{vmstat},
+@command{iostat}, @command{netstat}, and @command{ifstat}.  Dstat overcomes
+some of their limitations and adds some extra features, more counters and
+flexibility.  Dstat is handy for monitoring systems during performance tuning
+tests, benchmarks or troubleshooting.
+
+Dstat allows you to view all of your system resources in real-time, you can,
+e.g., compare disk utilization in combination with interrupts from your IDE
+controller, or compare the network bandwidth numbers directly with the disk
+throughput (in the same interval).")
+    (home-page "http://dag.wiee.rs/home-made/dstat/")
+    (license license:gpl2)))