summary refs log tree commit diff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2020-03-07 11:12:15 -0500
committerJan Nieuwenhuizen <janneke@gnu.org>2020-03-26 12:59:34 +0100
commit3d3ca76f1cde964aa61433cdd40dd701c39e60e7 (patch)
tree9a66a5434e01e398d05645d85e02eed7e35eaa94 /gnu/packages/admin.scm
parentc0a5cd1be3fce740c634596959321a76f22623a9 (diff)
downloadguix-3d3ca76f1cde964aa61433cdd40dd701c39e60e7.tar.gz
gnu: inetutils: Support for the Hurd.
* gnu/packages/linux.scm (net-tools)[supported-systems]: Remove the Hurd.
* gnu/packages/patches/inetutils-hurd.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/admin.scm (inetutils): Use it.  Disable some features on the
Hurd.
[native-inputs]: Include net-tools only on supported systems
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 4958d67b06..9662468b55 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -438,6 +438,7 @@ re-executing them as necessary.")
              (method url-fetch)
              (uri (string-append "mirror://gnu/inetutils/inetutils-"
                                  version ".tar.gz"))
+             (patches (search-patches "inetutils-hurd.patch"))
              (sha256
               (base32
                "05n65k4ixl85dc6rxc51b1b732gnmm8xnqi424dy9f1nz7ppb3xy"))))
@@ -449,13 +450,27 @@ re-executing them as necessary.")
                            ;; cross-compiling (by default it does not.)
                            ,@(if (%current-target-system)
                                  '("--with-path-procnet-dev=/proc/net/dev")
+                                 '())
+                           ,@(if (hurd-target?)
+                                 '("--disable-rcp"
+                                   "--disable-rexec"
+                                   "--disable-rexecd"
+                                   "--disable-rlogin"
+                                   "--disable-rlogind"
+                                   "--disable-rsh"
+                                   "--disable-rshd"
+                                   "--disable-uucpd"
+                                   "--disable-whois")
                                  '()))
        ;; On some systems, 'libls.sh' may fail with an error such as:
        ;; "Failed to tell switch -a apart from -A".
        #:parallel-tests? #f))
     (inputs `(("ncurses" ,ncurses)
               ("readline" ,readline)))        ;for 'ftp'
-    (native-inputs `(("netstat" ,net-tools))) ;for tests
+    (native-inputs (if (member (%current-system)
+                               (package-supported-systems net-tools))
+                       `(("netstat" ,net-tools))  ;for tests
+                       '()))
     (home-page "https://www.gnu.org/software/inetutils/")
     (synopsis "Basic networking utilities")
     (description