summary refs log tree commit diff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-12 15:54:59 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-12 23:23:25 -0400
commit023259c4bd1a38225fb1c06660c0cf393210e811 (patch)
tree21a5c7a3e27ca92a2f3947b32d164f167f1ce2f8 /gnu/packages/admin.scm
parent73d7247aacecbbe330203105b260a58683709063 (diff)
downloadguix-023259c4bd1a38225fb1c06660c0cf393210e811.tar.gz
gnu: inkscape: Rename variable to inkscape/stable and hide package.
This will allow introducing a new 'inkscape' package that can be more freely
upgraded on the main branch.

* gnu/packages/inkscape.scm (inkscape): Rename to...
(inkscape/stable): ... this, and make it a hidden package.
* gnu/packages/admin.scm (wpa-supplicant-gui)[native-inputs]: Rename inkscape
input accordingly.
* gnu/packages/docbook.scm (dblatex): Likewise.
* gnu/packages/gnome-xyz.scm (arc-theme): Likewise.
* gnu/packages/python-xyz.scm (python-matplotlib-documentation): Likewise.
(python-nbconvert): Likewise.
* gnu/packages/xfce.scm (xfdesktop): Likewise.
* gnu/packages/xorg.scm (hackneyed-x11-cursors): Likewise.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index dea58354d9..88cb8fded9 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2144,7 +2144,7 @@ command.")
     (native-inputs
      ;; For icons.
      (modify-inputs (package-native-inputs wpa-supplicant)
-       (prepend imagemagick inkscape)))
+       (prepend imagemagick inkscape/stable)))
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (add-after 'unpack 'chdir