summary refs log tree commit diff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-26 21:47:20 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-27 16:49:57 +0100
commit4f3506a48a120ace07a3e0c85f02381b305be6a0 (patch)
tree09d533d04a0b8e0893d586feab0c15cca6863ae2 /gnu/packages/admin.scm
parent63f931cf82460cecdeef2d147add07e5b671cc73 (diff)
downloadguix-4f3506a48a120ace07a3e0c85f02381b305be6a0.tar.gz
gnu: thermald: Update to 1.7.1.
* gnu/packages/admin.scm (thermald): Update to 1.7.1.
[arguments]: Substitute INVOKE for SYSTEM* and end phase with #t.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index cf9524eb5f..80cf8c391c 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2373,7 +2373,7 @@ make it a perfect utility on modern distros.")
 (define-public thermald
   (package
     (name "thermald")
-    (version "1.6")
+    (version "1.7.1")
     (source
      (origin
       (method url-fetch)
@@ -2381,7 +2381,7 @@ make it a perfect utility on modern distros.")
                           version ".tar.gz"))
       (file-name (string-append name "-" version ".tar.gz"))
       (sha256 (base32
-               "14klz9fnvi9jdlaqwrp61xa5nh051n8ykrs1fh1wxd7j66qf2fn6"))))
+               "0isgmav3z3nb5bsdya8m3haqhzj1lyfjx7i812cqfjrh2a9msin4"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
@@ -2389,6 +2389,7 @@ make it a perfect utility on modern distros.")
                    'unpack 'autogen.sh-and-fix-paths
                    (lambda* (#:key outputs #:allow-other-keys)
                      (let ((out (assoc-ref outputs "out")))
+                       ;; XXX this can probably be removed after version 1.7.1.
                        ;; upstartconfir is hardcoded to /etc/init and the build
                        ;; system tries to mkdir that.  We don't even need upstart
                        ;; files at all; this is a fast and kludgy workaround
@@ -2397,7 +2398,8 @@ make it a perfect utility on modern distros.")
                           (string-append "upstartconfdir = "
                                          out "/etc/init")))
                        ;; Now run autogen
-                       (zero? (system* "sh" "autogen.sh"))))))
+                       (invoke "sh" "autogen.sh")
+                       #t))))
        #:configure-flags
        (let ((out      (assoc-ref %outputs "out")))
          (list (string-append "--sysconfdir="