summary refs log tree commit diff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-11-16 11:15:49 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-11-16 11:16:10 +0200
commitd4560e0b7b518e749ea2089b3a76e8d033b45784 (patch)
tree13d1b5a7d392b540eecc608dc03358e1eab8d476 /gnu/packages/admin.scm
parent6e26bd5b7f01db15cfea0ee3f687cbf614814542 (diff)
downloadguix-d4560e0b7b518e749ea2089b3a76e8d033b45784.tar.gz
gnu: cpulimit: Make check phase conditional.
* gnu/packages/admin.scm (cpulimit)[arguments]: Only run custom 'check
phase when tests are enabled.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index becd15d523..e5f990f7ab 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2386,8 +2386,10 @@ lookup to YAML Mode.  You could enable the mode with @code{(add-hook
                     (lambda* (#:key make-flags #:allow-other-keys)
                       (apply invoke "make" "-Csrc" make-flags)))
                   (replace 'check
-                    (lambda* (#:key make-flags #:allow-other-keys)
-                      (apply invoke "make" "-Ctests" make-flags)))
+                    (lambda* (#:key tests? make-flags #:allow-other-keys)
+                      (when tests?
+                        (apply invoke "make" "-Ctests" make-flags))
+                      #t))
                   (replace 'install
                     (lambda* (#:key outputs #:allow-other-keys)
                       (let* ((out (assoc-ref outputs "out"))