summary refs log tree commit diff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-03-29 00:37:47 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-03-29 01:24:09 +0100
commita48cf78a8e61113d1987f93fc2632afcb5291175 (patch)
treeed242c080812590d75be95c1251348904133704d /gnu/packages/admin.scm
parente3fdc0197f3997f4f67918b07033e2878b98cd63 (diff)
downloadguix-a48cf78a8e61113d1987f93fc2632afcb5291175.tar.gz
gnu: thefuck: Update to 3.30.
* gnu/packages/admin.scm (thefuck): Update to 3.30.
[native-inputs]: Add go.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index c51dfad340..d85de15304 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -77,6 +77,7 @@
   #:use-module (gnu packages libbsd)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages lua)
+  #:use-module (gnu packages golang)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages imagemagick)
@@ -2474,7 +2475,7 @@ throughput (in the same interval).")
 (define-public thefuck
   (package
     (name "thefuck")
-    (version "3.29")
+    (version "3.30")
     (source
      (origin
        (method git-fetch)
@@ -2483,7 +2484,7 @@ throughput (in the same interval).")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1qhxwjjgrzpqrqjv7l2847ywpln76lyd6j8bl9gz2r6kl0fx2fqs"))
+        (base32 "0fnf78956pwhb9cgv1jmgypnkma5xzflkivfrkfiadbgin848yfg"))
        (patches (search-patches "thefuck-test-environ.patch"))))
     (build-system python-build-system)
     (arguments
@@ -2505,7 +2506,8 @@ throughput (in the same interval).")
        ("python-pyte" ,python-pyte)
        ("python-six" ,python-six)))
     (native-inputs
-     `(("python-mock" ,python-mock)
+     `(("go" ,go)
+       ("python-mock" ,python-mock)
        ("python-pytest" ,python-pytest)
        ("python-pytest-mock" ,python-pytest-mock)))
     (home-page "https://github.com/nvbn/thefuck")