summary refs log tree commit diff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorEric Dvorsak <eric@dvorsak.fr>2015-07-31 17:59:52 +0200
committerDavid Thompson <dthompson2@worcester.edu>2015-08-01 21:57:26 -0400
commit8d801045ff1e0cf44dc0fe9e06b101410e2c3dab (patch)
treec514a6062400da0db67d09cc2311e66a45233de4 /gnu/packages/admin.scm
parent29408532b4e7dd6a2bf8f176de702d173ce35cc0 (diff)
downloadguix-8d801045ff1e0cf44dc0fe9e06b101410e2c3dab.tar.gz
gnu: Move python2-ansible to (gnu packages admin).
    * gnu/packages/python.scm (python2-ansible): Move to ...
    * gnu/packages/admin.scm (ansible): ... here.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 1066d390f4..319e78c05a 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
 ;;; Copyright © 2015 Alex Sassmannshausen <alex.sassmannshausen@gmail.com>
+;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1171,3 +1172,43 @@ processing and time-series systems.  It's currently compatible with Graphite,
 Statsd, Librato and InfluxDB.  Graphios can emit Nagios metrics to any number
 of supported upstream metrics systems simultaneously.")
    (license license:gpl2+)))
+
+(define-public ansible
+  (package
+    (name "ansible")
+    (version "1.9.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/a/ansible/ansible-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "007fzgsqaahb0y4gjdxxmir9kcni7wph2z14jhqgpz88idrz8pn2"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python2-setuptools" ,python2-setuptools)
+       ("python2-pycrypto" ,python2-pycrypto)
+       ("python2-httplib2" ,python2-httplib2)
+       ("python2-passlib" ,python2-passlib)
+       ("python2-nose" ,python2-nose)
+       ("python2-mock" ,python2-mock)
+       ("python2-jinja2" ,python2-jinja2)
+       ("python2-pyyaml" ,python2-pyyaml)
+       ("python2-paramiko" ,python2-paramiko)))
+    (inputs
+     `(("python2-pycrypto" ,python2-pycrypto)
+       ("python2-jinja2" ,python2-jinja2)
+       ("python2-pyyaml" ,python2-pyyaml)
+       ("python2-paramiko" ,python2-paramiko)))
+    (arguments
+     `(#:python ,python-2)) ; incompatible with Python 3
+    (home-page "http://ansible.com/")
+    (synopsis "Radically simple IT automation")
+    (description "Ansible is a radically simple IT automation system.  It
+handles configuration-management, application deployment, cloud provisioning,
+ad-hoc task-execution, and multinode orchestration - including trivializing
+things like zero downtime rolling updates with load balancers.")
+    (license license:gpl3+)))