summary refs log tree commit diff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-05 13:39:15 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-05 18:29:54 +0200
commitddd871c18ab2d853503c167fd306fa8d84e99421 (patch)
tree2729e7ee89d20bfafa4ff2d042aba3be01075a6b /gnu/packages/admin.scm
parent9412762f9b092a89bf63054540909f84a577c1dd (diff)
downloadguix-ddd871c18ab2d853503c167fd306fa8d84e99421.tar.gz
gnu: thermald: Compile with -Werror again.
* gnu/packages/admin.scm (thermald)[arguments]: Remove substitution,
and a #t whilst we're here.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm8
1 files changed, 1 insertions, 7 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 551cd3666c..9bade4a850 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3660,13 +3660,7 @@ make it a perfect utility on modern distros.")
        (modify-phases %standard-phases
          (add-before 'bootstrap 'no-early-./configure
            (lambda _
-             (setenv "NO_CONFIGURE" "yet")
-             ;; XXX thd_trip_point.h redefines "__STDC_LIMIT_MACROS" after
-             ;; <xz>/include/lzma.h.  ./configure forcibly appends -Werror
-             ;; to CXXFLAGS, overriding any -Wno-error we'd add.
-             (substitute* "configure.ac"
-               (("-Werror") ""))
-             #t)))))
+             (setenv "NO_CONFIGURE" "yet"))))))
     (native-inputs
      `(("autoconf" ,autoconf)
        ("autoconf-archive" ,autoconf-archive)