summary refs log tree commit diff
path: root/gnu/packages/adns.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-09 22:48:45 +0200
committerMarius Bakke <marius@gnu.org>2021-05-09 23:12:48 +0200
commite2093c0f3e263e8ef99ea5ddf97110abb35e9c42 (patch)
tree7a2a4dc5f36ebdc29ce9aa11ceb0105c85379430 /gnu/packages/adns.scm
parentd954d7682da5e32e1ea4b744d1bd1591829eca68 (diff)
downloadguix-e2093c0f3e263e8ef99ea5ddf97110abb35e9c42.tar.gz
gnu: c-ares: Remove replacement package.
* gnu/packages/adns.scm (c-ares): Update to 1.17.1.
[arguments]: New field.
(c-ares/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/adns.scm')
-rw-r--r--gnu/packages/adns.scm31
1 files changed, 10 insertions, 21 deletions
diff --git a/gnu/packages/adns.scm b/gnu/packages/adns.scm
index 36f7211ad5..1b71d0107c 100644
--- a/gnu/packages/adns.scm
+++ b/gnu/packages/adns.scm
@@ -2,7 +2,7 @@
 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015, 2016, 2018, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2019, 2021 Marius Bakke <marius@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -65,7 +65,7 @@ scripts.")
 (define-public c-ares
   (package
     (name "c-ares")
-    (version "1.16.1")
+    (version "1.17.1")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -73,9 +73,15 @@ scripts.")
                     ".tar.gz"))
               (sha256
                (base32
-                "1kl6bzlcmxn0524h5qldlbh99wf96whhvk54w3p4igf3xk8150yh"))))
-    (replacement c-ares/fixed)
+                "0h7wjfnk2092glqcp9mqaax7xx0s13m501z1gi0gsjl2vvvd0gfp"))))
     (build-system gnu-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'filter-live-tests
+           (lambda _
+             ;; Filter tests that require internet access.
+             (setenv "GTEST_FILTER" "-*.Live*:*.FamilyV4*"))))))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (home-page "https://c-ares.haxx.se/")
@@ -88,23 +94,6 @@ The primary examples of such applications are servers which communicate with
 multiple clients and programs with graphical user interfaces.")
     (license (x11-style "https://c-ares.haxx.se/license.html"))))
 
-(define-public c-ares/fixed
-  (package
-    (inherit c-ares)
-    (name "c-ares")
-    (version "1.17.1")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://c-ares.haxx.se/download/" name "-" version
-                    ".tar.gz"))
-              (sha256
-               (base32
-                "0h7wjfnk2092glqcp9mqaax7xx0s13m501z1gi0gsjl2vvvd0gfp"))))
-    (arguments
-     `(;; FIXME: Some tests require network access
-       #:tests? #f))))
-
 ;; gRPC requires a c-ares built with CMake in order to get the .cmake modules.
 ;; We can not build c-ares itself with CMake because that would introduce a
 ;; circular dependency through nghttp2.