summary refs log tree commit diff
path: root/gnu/packages/agda.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-04-30 11:58:09 +0200
committerJosselin Poiret <dev@jpoiret.xyz>2023-06-04 10:59:33 +0200
commit7a00ab05320997aeb3796689faf3167662bff287 (patch)
treebf7a15a3d096c7fd47554c76136f5f38bb121e64 /gnu/packages/agda.scm
parentae29c9d26ef1bf90e45783c3ccad2b693a010b99 (diff)
downloadguix-7a00ab05320997aeb3796689faf3167662bff287.tar.gz
gnu: agda: Add AGDA_LIBDIRS search-path.
* gnu/packages/patches/agda-libdirs-env-variable.patch: New patch.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/agda.scm (agda): Patch agda, and add search path.
Diffstat (limited to 'gnu/packages/agda.scm')
-rw-r--r--gnu/packages/agda.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/agda.scm b/gnu/packages/agda.scm
index d6c2e1e231..c73c238a35 100644
--- a/gnu/packages/agda.scm
+++ b/gnu/packages/agda.scm
@@ -23,6 +23,7 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages agda)
+  #:use-module (gnu packages)
   #:use-module (gnu packages haskell-check)
   #:use-module (gnu packages haskell-web)
   #:use-module (gnu packages haskell-xyz)
@@ -51,7 +52,8 @@
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1s7zd01i8pmvi90ywx497kc07z50nah7h0fc2dn6jzb132k5sh1q"))))
+        (base32 "1s7zd01i8pmvi90ywx497kc07z50nah7h0fc2dn6jzb132k5sh1q"))
+       (patches (search-patches "agda-libdirs-env-variable.patch"))))
     (build-system haskell-build-system)
     (inputs
      (list ghc-aeson
@@ -109,6 +111,12 @@
                        (setenv "infodir" (string-append #$output
                                                         "/share/info"))
                        (invoke "make" "install-info"))))))))
+    (search-paths
+     (list (search-path-specification
+            (variable "AGDA_LIBDIRS")
+            (files (list "lib/agda")))))
+    (native-search-paths
+     search-paths)
     (home-page "https://wiki.portal.chalmers.se/agda/")
     (synopsis
      "Dependently typed functional programming language and proof assistant")