summary refs log tree commit diff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-24 13:36:56 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-24 13:46:39 +0100
commit67f39dd514c0efdaf50a474d59c433518e7d2134 (patch)
treec6adcdcfa7fbd3ac97c95c348c212fb8b03b8bdd /gnu/packages/algebra.scm
parentfe2bfabe8b83e86320481f71fd5ea0de2bbad66c (diff)
downloadguix-67f39dd514c0efdaf50a474d59c433518e7d2134.tar.gz
gnu: pari-gp: Address TeX errors.
* gnu/packages/algebra.scm (pari-gp)[native-inputs]: Replace texlive-tiny with
texlive-union of texlive-fonts-amsfonts and texlive-latex-amsfonts.
[arguments]: Use INVOKE in configure phase.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm65
1 files changed, 34 insertions, 31 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 46ad548e38..b19b7e692f 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -3,7 +3,7 @@
 ;;; Copyright © 2013, 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2016, 2017, 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2014, 2018 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
@@ -138,43 +138,46 @@ solve the shortest vector problem.")
 
 (define-public pari-gp
   (package
-   (name "pari-gp")
-   (version "2.11.1")
-   (source (origin
-            (method url-fetch)
-            (uri (string-append
-                  "https://pari.math.u-bordeaux.fr/pub/pari/unix/pari-"
-                  version ".tar.gz"))
-            (sha256
-              (base32
+    (name "pari-gp")
+    (version "2.11.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://pari.math.u-bordeaux.fr/pub/pari/unix/pari-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
                 "1jfax92jpydjd02fwl30r6b8kfzqqd6sm4yx94gidyz9lqjb7a94"))))
-   (build-system gnu-build-system)
-   (native-inputs `(("texlive" ,texlive-tiny)))
-   (inputs `(("gmp" ,gmp)
-             ("libx11" ,libx11)
-             ("perl" ,perl)
-             ("readline" ,readline)))
-   (arguments
-    '(#:make-flags '("all")
-      #:test-target "dobench"
-      #:phases (modify-phases %standard-phases
-                 (replace 'configure
-                          (lambda* (#:key outputs #:allow-other-keys)
-                           (let ((out (assoc-ref outputs "out")))
-                            (zero?
-                             (system* "./Configure"
-                                      (string-append "--prefix=" out)))))))))
-   (synopsis "PARI/GP, a computer algebra system for number theory")
-   (description
-    "PARI/GP is a widely used computer algebra system designed for fast
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("texlive" ,(texlive-union
+                    (list texlive-fonts-amsfonts
+                          texlive-latex-amsfonts)))))
+    (inputs `(("gmp" ,gmp)
+              ("libx11" ,libx11)
+              ("perl" ,perl)
+              ("readline" ,readline)))
+    (arguments
+     '(#:make-flags '("all")
+       #:test-target "dobench"
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda* (#:key outputs #:allow-other-keys)
+             (invoke "./Configure"
+                     (string-append "--prefix="
+                                    (assoc-ref outputs "out"))))))))
+    (synopsis "PARI/GP, a computer algebra system for number theory")
+    (description
+     "PARI/GP is a widely used computer algebra system designed for fast
 computations in number theory (factorisations, algebraic number theory,
 elliptic curves...), but it also contains a large number of other useful
 functions to compute with mathematical entities such as matrices,
 polynomials, power series, algebraic numbers, etc., and a lot of
 transcendental functions.
 PARI is also available as a C library to allow for faster computations.")
-   (license license:gpl2+)
-   (home-page "https://pari.math.u-bordeaux.fr/")))
+    (license license:gpl2+)
+    (home-page "https://pari.math.u-bordeaux.fr/")))
 
 (define-public gp2c
   (package