summary refs log tree commit diff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-09-21 21:47:56 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-09-21 21:47:56 +0200
commit39162ee49b08ccbd032324dc057fbafe8809c8a8 (patch)
tree181e0602ceeaa24bc0dad75bbd554eb37bf5d81a /gnu/packages/algebra.scm
parentb78891b0120c2e6f7752912d43bc59e18ed9c465 (diff)
downloadguix-39162ee49b08ccbd032324dc057fbafe8809c8a8.tar.gz
gnu: extempore: Only build on x86_64.
* gnu/packages/algebra.scm (kiss-fft-for-extempore)[supported-systems]:
Only build on x86_64.
* gnu/packages/gl.scm (nanovg-for-extempore)[supported-systems]:
Likewise.
* gnu/packages/image.scm (stb-image-for-extempore)[supported-systems]:
Likewise.
* gnu/packages/llvm.scm (llvm-for-extempore)[supported-systems]:
Likewise.
* gnu/packages/music.scm (portmidi-for-extempore)[supported-systems]:
Likewise.
(extempore)[supported-systems]: Likewise.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 83f03a074a..a15daf4ef8 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -521,6 +521,8 @@ syntax is similar to that of C, so basic usage is familiar.  It also includes
                 "0hkp9l6l4c92fb1l2sh6a6zv1hynpvb2s4d03vd8vxyvybc0l4pv"))))
     (build-system cmake-build-system)
     (arguments `(#:tests? #f)) ; no tests included
+    ;; Extempore refuses to build on architectures other than x86_64
+    (supported-systems '("x86_64-linux"))
     (home-page "https://github.com/extemporelang/kiss_fft")
     (synopsis "Mixed-radix Fast Fourier Transform")
     (description