summary refs log tree commit diff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-23 22:47:39 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-23 23:33:09 +0100
commit12abb19dfbd90089e04ccbc94f0bd8ee2cbe3729 (patch)
tree2c85197829465c6d48075166bd313d6c228508ef /gnu/packages/algebra.scm
parentbbb7a00e9a224d812a56c67956efb3e8a840cf0a (diff)
downloadguix-12abb19dfbd90089e04ccbc94f0bd8ee2cbe3729.tar.gz
gnu: Remove unnecessary closures around `arguments' value.
* gnu/packages/algebra.scm (pari-gp): Remove closure around the value of
  `arguments'.
* gnu/packages/bdb.scm (bdb): Likewise.
* gnu/packages/mit-krb5.scm (mit-krb5): Likewise.
* gnu/packages/openssl.scm (openssl): Likewise.
* gnu/packages/perl.scm (perl): Likewise.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm39
1 files changed, 19 insertions, 20 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 84806f9e3a..1fa98d2565 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -120,26 +120,25 @@ extensive test suite.")
              ("perl" ,perl)
              ("readline" ,readline)))
    (arguments
-    (lambda (system)
-      `(#:make-flags '("gp")
-;; FIXME: building the documentation requires tex; once this is available,
-;; replace "gp" by "all"
-        #:test-target "dobench"
-        #:phases
-        (alist-replace
-         'configure
-         (lambda* (#:key inputs outputs #:allow-other-keys)
-           (let ((out (assoc-ref outputs "out"))
-                 (readline (assoc-ref inputs "readline"))
-                 (gmp (assoc-ref inputs "gmp")))
-             (zero?
-              (system* "./Configure"
-                       (string-append "--prefix=" out)
-                       (string-append "--with-readline=" readline)
-                       (string-append "--with-gmp=" gmp)))))
-;; FIXME: readline and gmp will be detected automatically in the next
-;; stable release
-         %standard-phases))))
+    '(#:make-flags '("gp")
+      ;; FIXME: building the documentation requires tex; once this is available,
+      ;; replace "gp" by "all"
+      #:test-target "dobench"
+      #:phases
+      (alist-replace
+       'configure
+       (lambda* (#:key inputs outputs #:allow-other-keys)
+         (let ((out (assoc-ref outputs "out"))
+               (readline (assoc-ref inputs "readline"))
+               (gmp (assoc-ref inputs "gmp")))
+           (zero?
+            (system* "./Configure"
+                     (string-append "--prefix=" out)
+                     (string-append "--with-readline=" readline)
+                     (string-append "--with-gmp=" gmp)))))
+       ;; FIXME: readline and gmp will be detected automatically in the next
+       ;; stable release
+       %standard-phases)))
    (synopsis "PARI/GP, a computer algebra system for number theory")
    (description
     "PARI/GP is a widely used computer algebra system designed for fast