summary refs log tree commit diff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-08-14 17:46:31 +0200
committerAndreas Enge <andreas@enge.fr>2015-08-14 18:14:33 +0200
commit6c591c8ed729ea2f253a5337d35343a527c82e74 (patch)
treecef04994cd7e6e94ad5672c763451de11d0d7de7 /gnu/packages/algebra.scm
parent91430de6dfb8b05989d64ad0b4e3f5a01f8cce2a (diff)
downloadguix-6c591c8ed729ea2f253a5337d35343a527c82e74.tar.gz
gnu: flint: Update to 2.5.2.
* gnu/packages/algebra.scm (flint): Update to 2.5.2.
* gnu/packages/patches/flint-ldconfig.patch: New file.
* gnu-system.am (dist_patch_DATA): Register the patch.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 2d0804acc6..d3fe345d30 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -189,14 +189,15 @@ GP2C, the GP to C compiler, translates GP scripts to PARI programs.")
 (define-public flint
   (package
    (name "flint")
-   (version "2.4.5")
+   (version "2.5.2")
    (source (origin
             (method url-fetch)
             (uri (string-append
                   "http://flintlib.org/flint-"
                   version ".tar.gz"))
             (sha256 (base32
-                     "1qq11sxliy499a9g656dgk47ffb951q4gl6ddjbq838gy16kb2g4"))))
+                     "11syazv1a8rrnac3wj3hnyhhflpqcmq02q8pqk2m6g2k6h0gxwfb"))
+            (patches (map search-patch '("flint-ldconfig.patch")))))
    (build-system gnu-build-system)
    (propagated-inputs
     `(("gmp" ,gmp)
@@ -209,11 +210,6 @@ GP2C, the GP to C compiler, translates GP scripts to PARI programs.")
              (let ((out (assoc-ref outputs "out"))
                    (gmp (assoc-ref inputs "gmp"))
                    (mpfr (assoc-ref inputs "mpfr")))
-               ;; Drop test failing with gmp-6 due to changed invertibility
-               ;; of 0 in Z/1 Z, which according to the flint authors has no
-               ;; impact on flint.
-               ;; FIXME: Drop with later version.
-               (delete-file "fmpz/test/t-invmod.c")
                ;; do not pass "--enable-fast-install", which makes the
                ;; homebrew configure process fail
                (zero? (system*