summary refs log tree commit diff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-11-16 15:51:43 +0100
committerLudovic Courtès <ludo@gnu.org>2015-11-16 16:44:39 +0100
commita4eb83b709349ebbfe72ed473d0f65cdf5c4cbc7 (patch)
tree3360676fe44ac113b7f5d74aa63dd9d523adbacf /gnu/packages/algebra.scm
parent83a4a70b504e158055e384c6a0e267c1270c6beb (diff)
downloadguix-a4eb83b709349ebbfe72ed473d0f65cdf5c4cbc7.tar.gz
gnu: eigen: Fix 'Cflags' value in 'eigen3.pc'.
* gnu/packages/algebra.scm (eigen)[source]: Augment snippet to address
  <http://eigen.tuxfamily.org/bz/show_bug.cgi?id=1114>.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 07dfaafdc3..fb3b3e94b3 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -399,7 +399,11 @@ cosine/ sine transforms or DCT/DST).")
                ;; anyway, so just skip them.
                '(substitute* "CMakeLists.txt"
                   (("add_subdirectory\\(unsupported\\)")
-                   "# Do not build the tests for unsupported features.\n")))))
+                   "# Do not build the tests for unsupported features.\n")
+                  ;; Work around
+                  ;; <http://eigen.tuxfamily.org/bz/show_bug.cgi?id=1114>.
+                  (("\"include/eigen3\"")
+                   "\"${CMAKE_INSTALL_PREFIX}/include/eigen3\"")))))
     (build-system cmake-build-system)
     (arguments
      '(;; Turn off debugging symbols to save space.