summary refs log tree commit diff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2019-06-19 19:37:52 +0200
committerAndreas Enge <andreas@enge.fr>2019-06-19 23:45:29 +0200
commit37edfb0f1cdff251b1231d687041dfe6e7ea92e5 (patch)
treee840a57ca6f61aaf1f2ea5d54050c34b91ce8906 /gnu/packages/algebra.scm
parent3f9a027ce2016fdde41355f98ce44e66a2bb7980 (diff)
downloadguix-37edfb0f1cdff251b1231d687041dfe6e7ea92e5.tar.gz
gnu: Add m4ri.
* gnu/packages/algebra.scm (m4ri): New variable.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index fefe712a33..05733fa405 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1244,3 +1244,33 @@ with dense, sparse, and structured matrices over the integers and over
 finite fields.")
     (license license:lgpl2.1+)
     (home-page "https://linbox-team.github.io/linbox/")))
+
+(define-public m4ri
+  (package
+    (name "m4ri")
+    (version "20140914")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://bitbucket.org/malb/m4ri")
+                    (commit (string-append "release-" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0xfg6pffbn8r1s0y7bn9b8i55l00d41dkmhrpf7pwk53qa3achd3"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libpng" ,libpng)))
+    (synopsis "Arithmetic of dense matrices over F_2")
+    (description "M4RI is a library for fast arithmetic with dense matrices
+over F2.  The name M4RI comes from the first implemented algorithm: The
+Method of the Four Russians inversion algorithm published by Gregory Bard.
+This algorithm in turn is named after the Method of the Four Russians
+multiplication algorithm.")
+    (license license:gpl2+)
+    (home-page "https://bitbucket.org/malb/m4ri/")))