summary refs log tree commit diff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2020-09-23 14:14:09 +0200
committerAndreas Enge <andreas@enge.fr>2020-09-23 14:14:09 +0200
commit049a1714fc0dee6c69f216b6f2e4f43410f6fcac (patch)
treec3ffe607e4aaa0dddd556747439d83872e74bdaa /gnu/packages/algebra.scm
parent82f983da35c25c9cfd8f2a3b4fc9412f9ace0e04 (diff)
downloadguix-049a1714fc0dee6c69f216b6f2e4f43410f6fcac.tar.gz
gnu: fplll: Correct include files.
* gnu/packages/patches/fplll-std-fenv.patch: New patch.
* gnu/local.mk (dist_patch_DATA): Register patch.
* gnu/packages/algebra.scm (fplll): Use patch and move all inputs to
propagated-inputs.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 56a9a65366..16a1853483 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -160,14 +160,15 @@ line applications.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "06nyfidagp8pc2kfcw88ldgb2b1xm0a8z31n0sln7j72ihlmd8zj"))))
+                "06nyfidagp8pc2kfcw88ldgb2b1xm0a8z31n0sln7j72ihlmd8zj"))
+              (patches (search-patches "fplll-std-fenv.patch"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)
        ("libtool" ,libtool)
        ("pkg-config" ,pkg-config)))
-    (inputs
+    (propagated-inputs ; header files pulled in by fplll/defs.h
      `(("gmp" ,gmp)
        ("mpfr" ,mpfr)))
     (home-page "https://github.com/fplll/fplll")