summary refs log tree commit diff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-23 19:22:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-23 19:22:31 +0100
commitba902a15987b5ea2cd7adf2487229c2fe444931c (patch)
tree8633ad8522ef6f091ba9c63496ac9b6c7a0f0372 /gnu/packages/algebra.scm
parent2d3c9320731367427072a5b448fba857352db7cb (diff)
downloadguix-ba902a15987b5ea2cd7adf2487229c2fe444931c.tar.gz
gnu: eigen: Add upstream bugfix patch.
This fixes the build of nanopolish, imp, and others.

Reported by apteryx in #guix.

* gnu/packages/algebra.scm (eigen)[source]: Add patch.
* gnu/packages/patches/eigen-remove-openmp-error-counting.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 1c485a3f07..5b391449a0 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1017,7 +1017,8 @@ Optional thin wrappers allow usage of the library from other languages.")
                (base32
                 "1vxrsncfnkyq6gwxpsannpryp12mk7lc8f42ybvz3saf7icwc582"))
               (file-name (string-append name "-" version ".tar.bz2"))
-              (patches (search-patches "eigen-stabilise-sparseqr-test.patch"))
+              (patches (search-patches "eigen-remove-openmp-error-counting.patch"
+                                       "eigen-stabilise-sparseqr-test.patch"))
               (modules '((guix build utils)))
               (snippet
                ;; There are 3 test failures in the "unsupported" directory,