summary refs log tree commit diff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-11-16 15:52:56 +0100
committerLudovic Courtès <ludo@gnu.org>2015-11-16 16:44:39 +0100
commit354f4fe2926d52fcd767022cd9b5ded319807e0e (patch)
treec9771ffcca7e62d481c084ffb2273405e083869b /gnu/packages/algebra.scm
parenta4eb83b709349ebbfe72ed473d0f65cdf5c4cbc7 (diff)
downloadguix-354f4fe2926d52fcd767022cd9b5ded319807e0e.tar.gz
gnu: eigen: Use 'modify-phases'.
* gnu/packages/algebra.scm (eigen)[arguments]: Use 'modify-phases'
  instead of 'alist-cons-before'.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm23
1 files changed, 11 insertions, 12 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index fb3b3e94b3..41464ca882 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -413,19 +413,18 @@ cosine/ sine transforms or DCT/DST).")
        ;; <http://eigen.tuxfamily.org/index.php?title=Tests>.
        #:test-target "check"
 
-       #:phases (alist-cons-before
-                 'check 'build-tests
-                 (lambda _
-                   ;; First build the tests, in parallel.
-                   ;; See <http://eigen.tuxfamily.org/index.php?title=Tests>.
-                   (let* ((cores  (parallel-job-count))
-                          (dash-j (format #f "-j~a" cores)))
-                     ;; These variables are supposed to be honored.
-                     (setenv "EIGEN_MAKE_ARGS" dash-j)
-                     (setenv "EIGEN_CTEST_ARGS" dash-j)
+       #:phases (modify-phases %standard-phases
+                  (add-before 'check 'build-tests
+                    (lambda _
+                      ;; First build the tests, in parallel.
+                      ;; See <http://eigen.tuxfamily.org/index.php?title=Tests>.
+                      (let* ((cores  (parallel-job-count))
+                             (dash-j (format #f "-j~a" cores)))
+                        ;; These variables are supposed to be honored.
+                        (setenv "EIGEN_MAKE_ARGS" dash-j)
+                        (setenv "EIGEN_CTEST_ARGS" dash-j)
 
-                     (zero? (system* "make" "buildtests" dash-j))))
-                 %standard-phases)))
+                        (zero? (system* "make" "buildtests" dash-j))))))))
     (home-page "http://eigen.tuxfamily.org")
     (synopsis "C++ template library for linear algebra")
     (description